Opened 12 years ago

Closed 9 years ago

#52 closed defect (fixed)

NVIZ fails to display all points in a point vector map

Reported by: tvrusso Owned by: grass-dev@…
Priority: major Milestone: 6.4.0
Component: Tcl/Tk NVIZ Version: unspecified
Keywords: NVIZ, display, points Cc:
CPU: Unspecified Platform: Unspecified

Description

I observed some strange behavior in NVIZ while trying to work through examples in the 3rd edition of "Open Source GIS: A GRASS GIS Approach" by Markus Neteler and Helena Mitasova.

To reproduce:

  • download the nc_spm_06 GRASS location from http://www.grassbook.org/ under the Data Sets link for 3rd edition
  • Start GRASS with that location and run the command given in Chapter 3.1, First Steps, on page 33: g.region rast=elevation nviz elev=elevation vect=streams,roadsmajor, point=overpasses

When I run the last command, only a single overpass point is displayed. See first attached screenshot, where a single red sphere is visible.

However, if I change the region slightly, say by expanding it five meters in all directions:

g.region -p g.region n=228505 s=214995 e=645005 w=629995 nviz elev=elevation vect=streams,roadsmajor, point=overpasses

I then see all the points as they should have been, as displayed in second screenshot, where multiple points are visible.

This is with GRASS SVN checked out this morning (and was present in SVN for at least the last week, probably longer but this is the first time I checked).

Attachments (2)

Screenshot-NVIZ_bad.jpg (89.8 KB) - added by tvrusso 12 years ago.
NVIZ displaying improperly with region set to same as raster elevation
Screenshot-NVIZ_good.jpg (87.2 KB) - added by tvrusso 12 years ago.
NVIZ displaying properly, region set 5 meters larger on each side than elevation raster

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by tvrusso

Attachment: Screenshot-NVIZ_bad.jpg added

NVIZ displaying improperly with region set to same as raster elevation

Changed 12 years ago by tvrusso

Attachment: Screenshot-NVIZ_good.jpg added

NVIZ displaying properly, region set 5 meters larger on each side than elevation raster

comment:1 Changed 12 years ago by tvrusso

My GRASS commands got munged by the wiki formatting. They looked OK in the preview, but it should be clear where the line breaks should have been, separating the g.region and nviz commands.

comment:2 Changed 12 years ago by martinl

Component: defaultTcl

comment:3 Changed 11 years ago by neteler

Component: TclNVIZ

comment:4 Changed 10 years ago by marisn

CPU: Unspecified
Platform: Unspecified

I can not reproduce point issue with 6.4 r41200 on ~AMD64 Gentoo with nc_spm_08. Reporter - please retest with latest version. IMHO WORKSFORME.

Still I get different issue - lines (roads, rivers) are no displayed at all. Works fine in 6.5 (nviz && ogsf - candidates for sync with 6.5?)

comment:5 Changed 9 years ago by marisn

Resolution: fixed
Status: newclosed

Everything seems to be working just fine.

Note: See TracTickets for help on using tickets.