Opened 11 years ago

Closed 11 years ago

#503 closed defect (fixed)

wx-GUI: html-manual

Reported by: hellik Owned by: grass-dev@…
Priority: minor Milestone: 6.4.0
Component: Docs Version: 6.4.0 RCs
Keywords: Cc:
CPU: Unspecified Platform: Unspecified

Description

hi,

if you go to

http://grass.osgeo.org/grass64/manuals/html64_user/wxGUI.html

and scroll down, you see that the manual is three or four times in one html. the same is in the grass64rc3 (at least in the osgeo4w-grass64rc-2).

Change History (6)

comment:1 Changed 11 years ago by hellik

Component: wxGUIDocs

comment:2 Changed 11 years ago by hamish

Priority: majorminor

same for wxGUI.Nviz.html and others in gui/wxpython/docs/.

apparently the 'make htmldir' command there just appends the man pages to wxGUI.tmp.html instead of overwriting them so each time the dir is rebuilt the man page grows... I notice that 'make distclean' does not remove the *.tmp.html files in that dir.

Hamish

comment:3 Changed 11 years ago by neteler

Resolution: fixed
Status: newclosed

Fix (hack) submitted for devel_branch6 and 6.4.0svn: r36045 and r36046. GRASS 7 doesn't have this problem.

It will show up next by Saturday in the online manual. Closing ticket.

Markus

comment:4 Changed 11 years ago by hamish

Resolution: fixed
Status: closedreopened

reopening ticket, as the problem still happens and the fix actually does nothing.

'make distclean' does not remove gui/wxpython/docs/*.tmp.html. i.e. it's not about $(GISBASE)/docs/html/$$file.html, it's about the .tmp.html file in the source dir.

run "make" in gui/wxpython/docs/ a few times and watch them grow.

Two problems to fix as I see it:

  • 'make clean' does not clean up the .tmp.html files in docs/

and

  • 'make htmldir' is appending to instead of replacing the .tmp.html file.

not really sure about how to fix Makefile stuff, Hamish

comment:5 Changed 11 years ago by hamish

this version of the hack better addresses the symptom, but not the cause:

Index: gui/wxpython/docs/Makefile
===================================================================
--- gui/wxpython/docs/Makefile  (revision 36060)
+++ gui/wxpython/docs/Makefile  (working copy)
@@ -10,4 +10,4 @@
 include $(MODULE_TOPDIR)/include/Make/Rules.make
 
 default:
-       for file in $(FILES) ; do rm -f $(GISBASE)/docs/html/$$file.html; $(MAKE) htmldir PGM=$$file; done
+       for file in $(FILES) ; do rm -f $$file.tmp.html; $(MAKE) htmldir PGM=$$file; done

H

comment:6 Changed 11 years ago by neteler

Resolution: fixed
Status: reopenedclosed

Local tmp file removal submitted in changeset r36318 and r36319. Manual regenerated, seems ok now:

http://grass.osgeo.org/grass64/manuals/html64_user/wxGUI.html

Markus

Note: See TracTickets for help on using tickets.