Opened 11 years ago

Closed 8 years ago

#473 closed defect (wontfix)

GRASS fails to compile without curses

Reported by: marisn Owned by: grass-dev@…
Priority: major Milestone: 6.4.0
Component: Installation Version: unspecified
Keywords: configure, make Cc:
CPU: Unspecified Platform: Unspecified

Description

./configure --without-curses --with-cxx --enable-largefile --with-tcltk-includes=/usr/include/tcl --without-fftw --with-wxwidgets --with-python --with-freetype --with-postgres --with-postgres-includes=/usr/include/postgresql/ --with-freetype-includes=/usr/include/freetype2/ --enable-nls

gcc -I/home/pb/Desktop/grass-6.4.svn_src_snapshot_2009_01_31/dist.i686-pc-linux-gnu/include -g -O2 -fPIC -DPACKAGE=\""grasslibs"\" -DMAKE_VASK_LIB -DPACKAGE=\""grasslibs"\" -I/home/pb/Desktop/grass-6.4.svn_src_snapshot_2009_01_31/dist.i686-pc-linux-gnu/include -o OBJ.i686-pc-linux-gnu/V_acc.o -c V_acc.c In file included from V_acc.c:26: /home/pb/Desktop/grass-6.4.svn_src_snapshot_2009_01_31/dist.i686-pc-linux-gnu/include/grass/vask.h:5:20: error: curses.h: No such file or directory make: * [OBJ.i686-pc-linux-gnu/V_acc.o] Error 1

Change History (2)

comment:1 Changed 11 years ago by glynn

Not A Bug.

--without-curses is intended as a "hacking" option. If you use it, you're on your own (and any modules which use curses/vask aren't going to compile).

Given that it is almost never used, it wasn't deemed worth the effort of explicitly conditionalising libraries and modules upon $(USE_CURSES). Also, it's arguably better to have the list of missing libraries/modules in error.log.

7.0 doesn't use curses at all, so this isn't applicable there.

I'm leaving this open for now, as I'm not sure whether to resolve it as "invalid" or "wontfix".

comment:2 Changed 8 years ago by martinl

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.