Opened 11 years ago

Closed 11 years ago

#415 closed defect (fixed)

querying vector map crashes wxGUI

Reported by: msieczka Owned by: martinl
Priority: critical Milestone: 6.4.0
Component: wxGUI Version: svn-develbranch6
Keywords: Cc: grass-dev@…
CPU: x86-64 Platform: Linux

Description

In "edit mode":

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-
packages/wx-2.8-gtk2-unicode/wx/_core.py", line 14572, in
<lambda>

lambda event: event.callable(*event.args, **event.kw) )
  File "/usr/lib/python2.5/site-
packages/wx-2.8-gtk2-unicode/wx/lib/scrolledpanel.py", line
74, in _SetupAfter

self.SetVirtualSize(self.GetBestVirtualSize())
  File "/usr/lib/python2.5/site-
packages/wx-2.8-gtk2-unicode/wx/_core.py", line 14522, in
__getattr__

raise PyDeadObjectError(self.attrStr % self._name)
wx._core
.
PyDeadObjectError
:
The C++ part of the ScrolledPanel object has been deleted,
attribute access no longer allowed.
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-
packages/wx-2.8-gtk2-unicode/wx/_core.py", line 14572, in
<lambda>

lambda event: event.callable(*event.args, **event.kw) )
  File "/usr/lib/python2.5/site-
packages/wx-2.8-gtk2-unicode/wx/lib/scrolledpanel.py", line
74, in _SetupAfter

self.SetVirtualSize(self.GetBestVirtualSize())
  File "/usr/lib/python2.5/site-
packages/wx-2.8-gtk2-unicode/wx/_core.py", line 14522, in
__getattr__

raise PyDeadObjectError(self.attrStr % self._name)
wx._core
.
PyDeadObjectError
:
The C++ part of the ScrolledPanel object has been deleted,
attribute access no longer allowed.

In "display mode":

(Fri Dec 26 19:58:08 2008)
v.what --q -a map=mapa@PERMANENT east_north=594970.677739,5678071.967777 distance=42.521482                                                      
East: 594970.677739
North: 5678071.967777
Map: mapa 
Mapset: PERMANENT
Type: Line
Id: 1
Length: 6804.484567
Layer: 1
Category: 1
Driver: dbf
Database: /home/grassdata/caves_utm33/PERMANENT/dbf/
Table: mapa
Key column: cat
cat : 1
cusik : aha
uha : 986467345
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.5/threading.py", line 486, in
__bootstrap_inner
    self.run()
  File "/usr/local/grass-6.4.svn/etc/wxpython/gui_modules/go
utput.py", line 95, in run
    returncode=self.requestCmd.module.returncode,
AttributeError: 'NoneType' object has no attribute 'module'

Change History (5)

comment:1 Changed 11 years ago by martinl

Strange, I cannot reproduce the reported errors.

comment:2 in reply to:  1 Changed 11 years ago by martinl

Cc: grass-dev@… added
Owner: changed from grass-dev@… to martinl
Status: newassigned

Replying to martinl:

Strange, I cannot reproduce the reported errors.

Oh, right, you can get errors in display mode when clicking "too quickly" - attempt to fix in r35063 (devbr6), r35064 (trunk) and r35065 (relbr64).

comment:3 Changed 11 years ago by cmbarton

Resolution: worksforme
Status: assignedclosed

I just tested and have no errors. I tried to click as fast as I could and could not break it on Mac OS X. Please test on Linux and Windows.

comment:4 Changed 11 years ago by msieczka

Resolution: worksforme
Status: closedreopened

There was a fix by Martin Landa 3 days ago actually.

comment:5 Changed 11 years ago by msieczka

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.