Opened 12 months ago

Closed 9 months ago

#4003 closed defect (duplicate)

GRASS 7.8.1 still won't compile. Still a ctypes problem

Reported by: cmbarton Owned by: grass-dev@…
Priority: critical Milestone: 7.8.3
Component: Default Version: git-releasebranch78
Keywords: Cc:
CPU: Unspecified Platform: MacOSX

Description

I just tried to compile GRASS 7.8.1 with Python 3.7. It still fails with a ctypes error:

(anaconda_p3) TCLASHE-C02V435YJ1GQ:grass-7.8.1 cmbarton$ cd /Users/cmbarton/grass_source/grass-7.8.1/lib/python/ctypes
(anaconda_p3) TCLASHE-C02V435YJ1GQ:ctypes cmbarton$ make
/Applications/Xcode.app/Contents/Developer/usr/bin/make /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib
make[1]: `/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib' is up to date.
/Applications/Xcode.app/Contents/Developer/usr/bin/make OBJ.x86_64-apple-darwin18.7.0/date.py OBJ.x86_64-apple-darwin18.7.0/gis.py OBJ.x86_64-apple-darwin18.7.0/raster.py OBJ.x86_64-apple-darwin18.7.0/gmath.py OBJ.x86_64-apple-darwin18.7.0/proj.py OBJ.x86_64-apple-darwin18.7.0/imagery.py OBJ.x86_64-apple-darwin18.7.0/vector.py OBJ.x86_64-apple-darwin18.7.0/rtree.py OBJ.x86_64-apple-darwin18.7.0/display.py OBJ.x86_64-apple-darwin18.7.0/stats.py OBJ.x86_64-apple-darwin18.7.0/dbmi.py OBJ.x86_64-apple-darwin18.7.0/raster3d.py OBJ.x86_64-apple-darwin18.7.0/arraystats.py OBJ.x86_64-apple-darwin18.7.0/cluster.py OBJ.x86_64-apple-darwin18.7.0/vedit.py OBJ.x86_64-apple-darwin18.7.0/segment.py OBJ.x86_64-apple-darwin18.7.0/rowio.py OBJ.x86_64-apple-darwin18.7.0/temporal.py OBJ.x86_64-apple-darwin18.7.0/ogsf.py OBJ.x86_64-apple-darwin18.7.0/nviz.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/date.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/gis.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/raster.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/gmath.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/proj.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/imagery.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/vector.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/rtree.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/display.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/stats.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/dbmi.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/raster3d.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/arraystats.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/cluster.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/vedit.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/segment.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/rowio.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/temporal.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/ogsf.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/nviz.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/__init__.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/ctypes_preamble.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/ctypes_loader.py /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/date.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/gis.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/raster.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/gmath.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/proj.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/imagery.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/vector.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/rtree.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/display.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/stats.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/dbmi.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/raster3d.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/arraystats.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/cluster.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/vedit.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/segment.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/rowio.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/temporal.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/ogsf.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/nviz.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/__init__.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/ctypes_preamble.pyc /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python/grass/lib/ctypes_loader.pyc
make[1]: `OBJ.x86_64-apple-darwin18.7.0/date.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/gis.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/raster.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/gmath.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/proj.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/imagery.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/vector.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/rtree.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/display.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/stats.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/dbmi.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/raster3d.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/arraystats.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/cluster.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/vedit.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/segment.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/rowio.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/temporal.py' is up to date.
make[1]: `OBJ.x86_64-apple-darwin18.7.0/ogsf.py' is up to date.
GISRC=/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/demolocation/.grassrc78 GISBASE=/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0 PATH="/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/bin:/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/bin:/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/scripts:$PATH" LD_RUN_PATH="/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/bin:/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/bin:/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/scripts:/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/lib:/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/lib:/lib" PYTHONPATH="/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/etc/python:/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/gui/wxpython:$PYTHONPATH" LC_ALL=C LANG=C LANGUAGE=C ./ctypesgen.py --cpp "gcc -E -I/Applications/GRASS-7.8.app/Contents/Resources/include      -I/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/include -I/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/include -D__GLIBC_HAVE_LONG_LONG" -lgrass_nviz.7.8   /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/include/grass/nviz.h /Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/include/grass/defs/nviz.h -o OBJ.x86_64-apple-darwin18.7.0/nviz.py
Status: Preprocessing /var/folders/65/pp9w7z0d1mj502pj8hhl7vfw0000gp/T/tmp81n9l310.h
Status: gcc -E -I/Applications/GRASS-7.8.app/Contents/Resources/include      -I/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/include -I/Users/cmbarton/grass_source/grass-7.8.1/dist.x86_64-apple-darwin18.7.0/include -D__GLIBC_HAVE_LONG_LONG -U __GNUC__ -dD -U __BLOCKS__ "-Dinline=" "-D__inline__=" "-D__extension__=" "-D_Bool=uint8_t" "-D__const=const" "-D__asm__(x)=" "-D__asm(x)=" "-DCTYPESGEN=1" "-D__uint16_t=uint16_t" "-D__uint32_t=uint32_t" "-D__uint64_t=uint64_t" "/var/folders/65/pp9w7z0d1mj502pj8hhl7vfw0000gp/T/tmp81n9l310.h"
Traceback (most recent call last):
  File "./ctypesgen.py", line 162, in <module>
    descriptions = ctypesgencore.parser.parse(options.headers, options)
  File "/Users/cmbarton/grass_source/grass-7.8.1/lib/python/ctypes/ctypesgencore/parser/__init__.py", line 22, in parse
    parser.parse()
  File "/Users/cmbarton/grass_source/grass-7.8.1/lib/python/ctypes/ctypesgencore/parser/datacollectingparser.py", line 74, in parse
    ctypesparser.CtypesParser.parse(self, fname, False)
  File "/Users/cmbarton/grass_source/grass-7.8.1/lib/python/ctypes/ctypesgencore/parser/cparser.py", line 122, in parse
    self.preprocessor_parser.parse(filename)
  File "/Users/cmbarton/grass_source/grass-7.8.1/lib/python/ctypes/ctypesgencore/parser/preprocessor.py", line 173, in parse
    ppout, pperr = pp.communicate()
  File "/Applications/GRASS-7.8.app/Contents/Resources/lib/python3.7/subprocess.py", line 939, in communicate
    stdout, stderr = self._communicate(input, endtime, timeout)
  File "/Applications/GRASS-7.8.app/Contents/Resources/lib/python3.7/subprocess.py", line 1721, in _communicate
    self.stdout.errors)
  File "/Applications/GRASS-7.8.app/Contents/Resources/lib/python3.7/subprocess.py", line 816, in _translate_newlines
    data = data.decode(encoding, errors)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xa5 in position 2244622: invalid start byte
make[1]: *** [OBJ.x86_64-apple-darwin18.7.0/nviz.py] Error 1
make: *** [default] Error 2 

Attachments (1)

err.txt (5.3 KB) - added by annakrat 12 months ago.
actual error

Download all attachments as: .zip

Change History (6)

Changed 12 months ago by annakrat

Attachment: err.txt added

actual error

comment:1 Changed 12 months ago by annakrat

This is likely duplicate of #3883. From a previous analysis of the problem couple months ago, the standard output has some broken characters causing the error above. The actual error is attached.

comment:2 Changed 12 months ago by neteler

Milestone: 7.8.2

Ticket retargeted after milestone closed

comment:3 Changed 12 months ago by neteler

Milestone: 7.8.3

comment:4 Changed 9 months ago by nila

I would say this is certainly a duplicate of #3883, to which a fix has been committeed to both master and 7.8 branch.

This may be closed as duplicate.

comment:5 Changed 9 months ago by annakrat

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.