Opened 2 years ago

Closed 2 years ago

#3980 closed defect (invalid)

Error Reading list of LiDAR files in r.in.lidar 7.6.1, 7.8.1 on Windows 10

Reported by: dnewcomb Owned by: grass-dev@…
Priority: normal Milestone: 7.8.2
Component: Default Version: git-releasebranch78
Keywords: Cc:
CPU: x86-64 Platform: MSWindows

Description

I suspect that this is a windows limitation, since I have had no issues on Linux. When running r.in.lidar on Windows 10 64 bit computer using an input text file with 1870 lines

Exception in thread Thread-29: Traceback (most recent call last):

File "C:\Program Files\GRASS GIS

7.8\Python37\lib\threading.py", line 917, in _bootstrap_inner

self.run()

File "C:\Program Files\GRASS GIS

7.8\gui\wxpython\core\gconsole.py", line 162, in run

self.resultQ.put((requestId, self.requestCmd.run()))

File "C:\Program Files\GRASS GIS

7.8\gui\wxpython\core\gcmd.py", line 606, in run

self._redirect_stream()

File "C:\Program Files\GRASS GIS

7.8\gui\wxpython\core\gcmd.py", line 635, in _redirect_stream

self.stderr.write(line)

File "C:\Program Files\GRASS GIS

7.8\gui\wxpython\core\gconsole.py", line 306, in write

self.message += line.split(':', 1)[1].strip() + '\n'

IndexError?: list index out of range

This occurs on both 7.6.1 and 7.8.1 for windows

Change History (6)

comment:1 Changed 2 years ago by dnewcomb

Sorry, forgot to add that r.in.lidar never completes.

comment:2 Changed 2 years ago by wenzeslaus

The error (below) seems unrelated to r.in.lidar becasue it is not coming from there since it is GUI related (this is Python traceback with wxpython involved, r.in.lidar is C). Do you observe it only with r.in.lidar file=...? What are the steps leading to this error?

...
 7.8\gui\wxpython\core\gconsole.py", line 306, in write

    self.message += line.split(':', 1)[1].strip() + '\n'

IndexError?: list index out of range 

comment:3 Changed 2 years ago by marisn

Check the version of libLAS as there where bugs in its C API causing segfaults:
https://github.com/libLAS/libLAS/pull/168
https://github.com/libLAS/libLAS/pull/173

comment:4 Changed 2 years ago by dnewcomb

Checking back, running from the command line and not the GUI resulted in successful completion of the command for 1870 tiles on Windows. I can confirm that the errors above seem to be related to just the gui.

One side note, instead of seeing a standard percent completion updated for the duration of the command, a repeating 100% was printed while the command was processing. I assume that it was reporting 100% as each tile was completed?

The raster product appears to have been created successfully.

comment:5 in reply to:  4 Changed 2 years ago by wenzeslaus

Keywords: Python input file list removed

Replying to dnewcomb:

Checking back, running from the command line and not the GUI resulted in successful completion of the command for 1870 tiles on Windows. I can confirm that the errors above seem to be related to just the gui.

Can you perhaps close this one as invalid and, if you can reproduce it, create a new one with steps how to reproduce it (and link it here).

One side note, instead of seeing a standard percent completion updated for the duration of the command, a repeating 100% was printed while the command was processing. I assume that it was reporting 100% as each tile was completed?

Makes sense. You can create a ticket for that.

Replying to marisn:

Check the version of libLAS as there where bugs in its C API causing segfaults:...

Thanks for the update and the PR too!

comment:6 Changed 2 years ago by dnewcomb

Resolution: invalid
Status: newclosed

As requested

Note: See TracTickets for help on using tickets.