Opened 9 months ago

Closed 8 months ago

#3934 closed defect (fixed)

wxGUI: Python error on "Set color table interactively" tool

Reported by: neteler Owned by: grass-dev@…
Priority: normal Milestone: 7.8.2
Component: wxGUI Version: git-releasebranch78
Keywords: python3, colors Cc:
CPU: Unspecified Platform: Unspecified

Description

When using right mouse menu on a raster map to run the interactive color tool, the following error appears:

Traceback (most recent call last):
  File "/home/mneteler/software/grass78_git/dist.x86_64-pc-
linux-gnu/gui/wxpython/modules/colorrules.py", line 981, in
OnSelectionInput

'max': self.properties['max']})
TypeError
:
%d format: a number is required, not NoneType
/home/mneteler/software/grass78_git/dist.x86_64-pc-linux-
gnu/gui/wxpython/modules/colorrules.py:1986:
wxPyDeprecationWarning: Call to deprecated item
BitmapFromImage. Use :class:`wx.Bitmap` instead
  bitmap = wx.BitmapFromImage(img)

Change History (4)

comment:1 Changed 9 months ago by neteler

Milestone: 7.8.17.8.2

Ticket retargeted after milestone closed

comment:2 Changed 8 months ago by annakrat

I can't reproduce this error, only the wx.Bitmap part which is fixed in https://github.com/OSGeo/grass/pull/230.

comment:3 in reply to:  2 Changed 8 months ago by neteler

Replying to annakrat:

I can't reproduce this error, only the wx.Bitmap part which is fixed in https://github.com/OSGeo/grass/pull/230.

Thanks, this PR fixes the issue and brings the "Set color table interactively" tool back.

comment:4 Changed 8 months ago by annakrat

Resolution: fixed
Status: newclosed

Merged and backported.

Note: See TracTickets for help on using tickets.