Opened 6 months ago

Closed 6 months ago

Last modified 5 months ago

#3922 closed defect (duplicate)

GRASS fails to start with C or POSIX locale

Reported by: marisn Owned by: grass-dev@…
Priority: normal Milestone: 7.8.1
Component: Python Version: git-releasebranch78
Keywords: Cc:
CPU: Unspecified Platform: Linux

Description

The new gettext magick needs some work:

LC_ALL=C bin.x86_64-pc-linux-gnu/grass79 
Default locale not found, using UTF-8
Default locale settings are missing. GRASS running with C locale.Traceback (most recent call last):
  File "bin.x86_64-pc-linux-gnu/grass79", line 2204, in <module>
    main()
  File "bin.x86_64-pc-linux-gnu/grass79", line 2082, in main
    message(_("Starting GRASS GIS..."))
NameError: name '_' is not defined
locale -a
C
C.utf8
en_US.utf8
lv_LV.utf8
pl_PL
pl_PL.utf8
POSIX

Change History (5)

comment:1 Changed 6 months ago by annakrat

Resolution: duplicate
Status: newclosed

Duplicate of #3857

comment:2 in reply to:  1 Changed 6 months ago by marisn

Resolution: duplicate
Status: closedreopened

Replying to annakrat:

Duplicate of #3857

Try again as it has nothing to do with r.mapcalc ;-)

comment:3 Changed 6 months ago by annakrat

Resolution: duplicate
Status: reopenedclosed

Here you go: #3875.

comment:5 Changed 5 months ago by neteler

Milestone: 7.8.1
Version: svn-trunkgit-releasebranch78
Note: See TracTickets for help on using tickets.