Opened 5 years ago

Closed 5 years ago

#3894 closed defect (fixed)

g.gui.animation fails to export animation with python3 error

Reported by: veroandreo Owned by: grass-dev@…
Priority: normal Milestone: 7.8.0
Component: wxGUI Version: git-releasebranch78
Keywords: g.gui.animation, python3 Cc:
CPU: Unspecified Platform: Unspecified


When I try to export a GIF animation from G7:g.gui.animation, I get the following error:

Traceback (most recent call last):
  File "/home/veroandreo/software/grass78_git/dist.x86_64-pc-linux-gnu/gui/wxpython/animation/", line 1516, in OnExport
  File "/home/veroandreo/software/grass78_git/dist.x86_64-pc-linux-gnu/etc/python/grass/pydispatch/", line 229, in emit
    dispatcher.send(signal=self, *args, **kwargs)
  File "/home/veroandreo/software/grass78_git/dist.x86_64-pc-linux-gnu/etc/python/grass/pydispatch/", line 349, in send
  File "/home/veroandreo/software/grass78_git/dist.x86_64-pc-linux-gnu/etc/python/grass/pydispatch/", line 60, in robustApply
    return receiver(*arguments, **named)
  File "/home/veroandreo/software/grass78_git/dist.x86_64-pc-linux-gnu/gui/wxpython/animation/", line 622, in _export
    pilImages = [WxImageToPil(image) for image in images]
  File "/home/veroandreo/software/grass78_git/dist.x86_64-pc-linux-gnu/gui/wxpython/animation/", line 622, in <listcomp>
    pilImages = [WxImageToPil(image) for image in images]
  File "/home/veroandreo/software/grass78_git/dist.x86_64-pc-linux-gnu/gui/wxpython/animation/", line 274, in WxImageToPil
  File "/usr/lib64/python3.7/site-packages/PIL/", line 812, in frombytes
    s = d.decode(data)
TypeError: argument 1 must be read-only bytes-like object, not bytearray

Change History (3)

comment:1 by veroandreo, 5 years ago

I recompiled my 78 rel branch installation yesterday and I still get the same error, was this backported??

I cannot test in dev because the new image collections broke the temporal database and I have to rebuild it.

comment:2 by neteler, 5 years ago

I have backported it just now to relr78.

comment:3 by veroandreo, 5 years ago

Resolution: fixed
Status: newclosed

After the backport, I do not get this error anymore in 78 rel branch. Closing.

Note: See TracTickets for help on using tickets.