Opened 16 months ago

Closed 5 months ago

#3800 closed defect (fixed)

g.gui.gcp Wizard fails

Reported by: nila Owned by: grass-dev@…
Priority: critical Milestone: 7.8.3
Component: wxGUI Version: unspecified
Keywords: georeferencing Cc:
CPU: x86-64 Platform: MacOSX

Description

The g.gui.gcp Wizard fail with 7.6.0 due to two problem. One is fixed in trunk (grass/trunk/gui/wxpython/gcp/manager.py:43-48) and is namespace related.

The other issue is caused by the line https://trac.osgeo.org/grass/browser/grass/trunk/gui/wxpython/gcp/manager.py?rev=73229#L2178

    self.InsertColumnInfo(idx_col, info)

which fails with the message "GCPList' object has no attribute 'InsertColumnInfo?"

replacing this with:

    self.InsertColumn(idx_col, info)

solves the problem for me.

Tested with GRASS GIS 7.6.0 | Python 2.7.15 | wxPython 4.0.3

Change History (3)

comment:1 Changed 7 months ago by neteler

Milestone: 7.8.3

comment:2 Changed 5 months ago by nila

This issue have been solved for master and 7.8 branch with commit 931490c

If there are no wishes to backport this to 7.6, this ticket may be closed.

comment:3 Changed 5 months ago by annakrat

Resolution: fixed
Status: newclosed

There has been many more fixes for wxPython 4 in 7.8, so I would recommend switching to that.

Note: See TracTickets for help on using tickets.