#3684 closed defect (invalid)

Querying a raster layer outside its extent in wxGUI doesn't clear previous results

Reported by: hcho Owned by: grass-dev@…
Priority: normal Milestone:
Component: wxGUI Version: svn-trunk
Keywords: Cc:
CPU: Unspecified Platform: Unspecified

Description

Steps to reproduce this issue:

  1. Query a null pixel => No results
  2. Query a non-null pixel => Valid results
  3. Query a null pixel again => Results from step 2 don't get cleared. Can be misleading.

Change History (5)

comment:1 Changed 16 months ago by hcho

FYI, vector query properly clears previous results.

comment:2 Changed 16 months ago by annakrat

Hmm, I can't reproduce it, somebody else?

comment:3 Changed 16 months ago by marisn

I also can not reproduce, but I do get a warning in Terminal. Could there be an edge case with stderr messing things up?

GRASS_INFO_WARNING(14721,1): 388905.055487 165780.517879 is outside your current region
GRASS_INFO_END(14721,1)

comment:4 Changed 16 months ago by hcho

Hmm... I updated and recompile my trunk. Now, I cannot reproduce it either. It was the "urban" raster map in the NC sample dataset. Closing it for now.

comment:5 Changed 16 months ago by hcho

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.