Opened 22 months ago

Closed 4 months ago

#3652 closed defect (fixed)

Map display exception when switching to vector digitizer mode

Reported by: balagates Owned by: grass-dev@…
Priority: minor Milestone: 7.8.3
Component: wxGUI Version: 7.4.0
Keywords: Cc:
CPU: OSX/Intel Platform: MacOSX

Description

If you have a vector drawn in the map window the first time you change the mode from "2D View" to "Vector digitizer" it clears the map window and in the console I see an exception:

Traceback (most recent call last):
  File
"/opt/local/share/grass-7.4.0/gui/wxpython/core/gthread.py",
line 117, in OnDone

event.ondone(event)
  File
"/opt/local/share/grass-7.4.0/gui/wxpython/core/render.py",
line 442, in OnRenderDone

self.updateProgress.emit(layer=self.layer)
  File "/opt/local/share/grass-7.4.0/etc/python/grass/pydisp
atch/signal.py", line 229, in emit

dispatcher.send(signal=self, *args, **kwargs)
  File "/opt/local/share/grass-7.4.0/etc/python/grass/pydisp
atch/dispatcher.py", line 349, in send

**named
  File "/opt/local/share/grass-7.4.0/etc/python/grass/pydisp
atch/robustapply.py", line 60, in robustApply

return receiver(*arguments, **named)
  File
"/opt/local/share/grass-7.4.0/gui/wxpython/core/render.py",
line 717, in ReportProgress

self.renderDone.emit()
  File "/opt/local/share/grass-7.4.0/etc/python/grass/pydisp
atch/signal.py", line 229, in emit

dispatcher.send(signal=self, *args, **kwargs)
  File "/opt/local/share/grass-7.4.0/etc/python/grass/pydisp
atch/dispatcher.py", line 349, in send

**named
  File "/opt/local/share/grass-7.4.0/etc/python/grass/pydisp
atch/robustapply.py", line 60, in robustApply

return receiver(*arguments, **named)
  File
"/opt/local/share/grass-7.4.0/gui/wxpython/core/render.py",
line 623, in OnRenderDone

raise GException(_("Rendering failed: %s" % msg))
core.gcmd
.
GException
:
Rendering failed: Expecting 825x586 image but got 825x622
image.

One workaround after the exception is to click on the "Render Map" icon.

I suspect the problem is that the switch to "Vector digitizer" mode adds a row of toolbar icons reducing the area to draw the image but the size change has not propogated to everything that needs it. Interestingly switching modes back to "2D View" and then to "Vector digitizer" a second time does not produce the error even though the vector digitizer toolbar disappears and then is re-added.

Change History (4)

comment:1 Changed 7 months ago by neteler

Milestone: 7.8.3

comment:2 Changed 4 months ago by nila

A fix for this issue has been proposed with PR456.

See also #3487.

comment:3 Changed 4 months ago by nila

This issue is with 7.8.2dev and master (7.9dev) not reproducible, seem to have been fixed at some stage (independent of PR456. The ticket may be closed.

comment:4 Changed 4 months ago by annakrat

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.