#3506 closed defect (fixed)

3D view mode not available: Reason: name '__int64' is not defined

Reported by: hellik Owned by: grass-dev@…
Priority: major Milestone: 7.6.0
Component: wxGUI Version: svn-trunk
Keywords: Cc:
CPU: Unspecified Platform: MSWindows 8

Description

tested with

System Info                                                                     
GRASS version: 7.5.svn                                                          
GRASS SVN revision: r72285                                                      
Build date: 2018-01-27                                                          
Build platform: x86_64-w64-mingw32                                              
GDAL: 2.2.3                                                                     
PROJ.4: 4.9.3                                                                   
GEOS: 3.5.0                                                                     
SQLite: 3.17.0                                                                  
Python: 2.7.5                                                                   
wxPython: 2.8.12.1                                                              
Platform: Windows-8-6.2.9200 (OSGeo4W)  

after starting the GUI, there is following error message in the wxGUI output window:

3D view mode not available: Reason: name '__int64' is not defined 

Change History (6)

comment:1 Changed 20 months ago by mmetz

Milestone: 7.4.17.6.0
Version: 7.4.0svn-trunk

Applies to trunk only. It seems to be a ctypes problem with the new 64 integer type.

comment:2 in reply to:  1 ; Changed 20 months ago by mmetz

Replying to mmetz:

Applies to trunk only. It seems to be a ctypes problem with the new 64 integer type.

The problem is apparently in ctypedescs.py: the ctypes_type_map does not include __int64 if sys.platform == 'win32'

comment:3 in reply to:  2 Changed 20 months ago by hellik

Replying to mmetz:

Replying to mmetz:

Applies to trunk only. It seems to be a ctypes problem with the new 64 integer type.

The problem is apparently in ctypedescs.py: the ctypes_type_map does not include __int64 if sys.platform == 'win32'

tested now with

System Info                                                                     
GRASS version: 7.5.svn                                                          
GRASS SVN revision: r72331                                                      
Build date: 2018-03-07                                                          
Build platform: x86_64-w64-mingw32                                              
GDAL: 2.2.3                                                                     
PROJ.4: 4.9.3                                                                   
GEOS: 3.5.0                                                                     
SQLite: 3.17.0                                                                  
Python: 2.7.5                                                                   
wxPython: 2.8.12.1                                                              
Platform: Windows-8-6.2.9200 (OSGeo4W)
Starting 3D view mode...                                                        
Loading raster map <elevation@PERMANENT>...
Loading raster map <elevation@PERMANENT>...
Translating colors from raster map <elevation@PERMANENT>...
Switching back to 2D view mode...                                               
Raster map <elevation@PERMANENT> unloaded successfully  

r72328 seems to fix this issue.

comment:4 Changed 20 months ago by martinl

Feel free to close the issue...

comment:5 in reply to:  4 ; Changed 20 months ago by hellik

Replying to martinl:

Feel free to close the issue...

not sure if anything more is needed; maybe mmetz can answer this.

comment:6 in reply to:  5 Changed 20 months ago by mmetz

Resolution: fixed
Status: newclosed

Replying to hellik:

Replying to martinl:

Feel free to close the issue...

not sure if anything more is needed; maybe mmetz can answer this.

Nothing else needed, closing as fixed.

Note: See TracTickets for help on using tickets.