Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#3488 closed defect (fixed)

v.in.ogr mangeling of column names when imporing OSM geojson extracts

Reported by: alice Owned by: grass-dev@…
Priority: normal Milestone: 7.4.1
Component: Vector Version: svn-releasebranch74
Keywords: v.in.ogr Cc:
CPU: All Platform: Linux

Description

I tried to import geojson extracts from http://overpass-turbo.eu/ with the query highway=* and type:way for the area of Bonn. When importing it with v.in.ogr appeared:

Error in sqlite3_prepare():
duplicate column name: sloped_curb_end

This happens whenever changing the column names from name:name to name_name, and whenever name_name is already existing in the dataset, it stops and gives an error.

It would be nice to find a different solution while changing : of the initial column names, maybe with whenever changing a : into _ adding a 1 at the end of the new name in order to prevent the creation of duplicates.

Geojson file attached.

Attachments (1)

bonn_streets_OSM _EPSG4326.zip (144.2 KB) - added by alice 2 years ago.
Geojson sample data to reproduce error

Download all attachments as: .zip

Change History (6)

Changed 2 years ago by alice

Geojson sample data to reproduce error

comment:1 Changed 2 years ago by mmetz

Resolution: fixed
Status: newclosed

In 72209:

v.in.ogr: fix duplicate column names (fixes #3488)

comment:2 in reply to:  1 Changed 2 years ago by mmetz

Resolution: fixed
Status: closedreopened

Replying to mmetz:

In 72209:

v.in.ogr: fix duplicate column names (fixes #3488)

Re-opening because it is not yet fixed in relbr74

comment:3 Changed 2 years ago by neteler

Resolution: fixed
Status: reopenedclosed

In 72215:

v.in.ogr: fix duplicate column names (trunk, r72209; fixes #3488)

comment:4 in reply to:  3 Changed 2 years ago by mmetz

Replying to neteler:

In 72215:

v.in.ogr: fix duplicate column names (trunk, r72209; fixes #3488)

Is it working for you now?

comment:5 Changed 2 years ago by alice

Perfect, it is working now! Thank you!

Note: See TracTickets for help on using tickets.