Opened 23 months ago

Last modified 6 months ago

#3471 reopened defect

Custom dropdown control doesn’t recognize mouse events

Reported by: cmbarton Owned by: grass-dev@…
Priority: major Milestone: 7.6.2
Component: wxGUI Version: 7.2.2
Keywords: wxPython, dropdown control Cc:
CPU: Unspecified Platform: MacOSX

Description

A custom drop-down list control does not respond to mouse scroll and mouse down events in wxPython 3 and above. It does respond to arrow key events. While this might be fixable in the rather convoluted custom control code, It is not clear why this control is even needed now.

Look at g.mapset. Mapset name is a standard drop-down list and works fine. Location name is the custom control and does not. This control is used sporadically in only a few places. It would be best to replace it with a standard wxPython control.

Change History (10)

comment:1 Changed 22 months ago by cmbarton

Resolution: fixed
Status: newclosed

Checking the new Mac binaries, this seems to be fixed in version 7.2.2. I will close unless I run into it again.

comment:2 Changed 21 months ago by cmbarton

Priority: normalmajor
Resolution: fixed
Status: closedreopened

I was wrong. This is still a problem. In fact, the dropdown menu is now invisible. See settings/grass working environment/change location and mapset. The change mapset control cannot be used at all. Upgrading to major (maybe should be critical) since it makes a set of functions completely unusable.

comment:3 Changed 20 months ago by martinl

Milestone: 7.2.3

Ticket retargeted after milestone closed

comment:4 Changed 20 months ago by martinl

Milestone: 7.2.4

comment:5 Changed 18 months ago by annakrat

I replaced MapsetSelect? with simpler widget in r72754. Needs more testing, it's used in

  • Settings - Change location and mapset/Change mapset
  • Add multiple maps dialog
  • in module dialogs, e.g. g.mapsets - allows multiple mapsets

comment:6 Changed 18 months ago by cmbarton

Thanks. I will recompile as soon as I can, maybe tomorrow if all goes well, and test. If not tomorrow, then the beginning of next week.

comment:7 Changed 18 months ago by cmbarton

I've compiled trunk and this seems to fix the problem. I tested on several modules and found no problems. I'm testing with wxPython 4.0.0. When this is back ported to 7.2 and 7.4 and tested, we can close. Thanks much.

comment:8 Changed 17 months ago by annakrat

In 72856:

wxGUI: use simpler widget for MapsetSelect? to avoid wxWidgets bug #17771 on mac (merge from trunk, see #3471)

comment:9 Changed 17 months ago by annakrat

Resolution: fixed
Status: reopenedclosed

comment:10 Changed 6 months ago by cmbarton

Milestone: 7.2.47.6.2
Resolution: fixed
Status: closedreopened

Reopening. I thought these were all fixed. But I recently found more of these drop downs in the analytical dialogs accessible from the display window menu bar. These include the profiler, histogrammer, bivariate scatterplot tool. If this pull down is controlled by a single piece of code somewhere for these modules, it can be easily fixed like the other instances. I'll move the milestone up to the current stable version too.

Note: See TracTickets for help on using tickets.