Opened 2 years ago

Closed 2 years ago

#3432 closed defect (duplicate)

Use SFD above this threshold - infinity doesn't work in r.stream.extract

Reported by: hellik Owned by: grass-dev@…
Priority: normal Milestone: 7.4.0
Component: Raster Version: svn-trunk
Keywords: Cc:
CPU: x86-64 Platform: MSWindows 8

Description

r.stream.extract elevation=elevation@PERMANENT threshold=100 stream_raster=rstream
Performs stream network extraction.
Usage:
 r.stream.extract elevation=name [accumulation=name]
[depression=name]
   threshold=value [d8cut=value] [mexp=value]
[stream_length=value]
   [memory=value] [stream_raster=name] [stream_vector=name]
   [direction=name] [--overwrite] [--help] [--verbose]
[--quiet] [--ui]
Flags:
Parameters:
      elevation   Name of input elevation raster map
   accumulation   Name of input accumulation raster map
     depression   Name of input raster map with real
depressions
      threshold   Minimum flow accumulation for streams
          d8cut   Use SFD above this threshold
                  default: infinity
           mexp   Montgomery exponent for slope, disabled
with 0
                  default: 0
  stream_length   Delete stream segments shorter than
stream_length cells
                  default: 0
         memory   Maximum memory to be used (in MB)
                  default: 300
  stream_raster   Name for output raster map with unique
stream ids
  stream_vector   Name for output vector map with unique
stream ids
      direction   Name for output raster map with flow
direction
ERROR: Missing value for parameter <d8cut>

tested with

System Info                                                                     
GRASS version: 7.3.svn                                                          
GRASS SVN revision: r71600                                                      
Build date: 2017-10-27                                                          
Build platform: x86_64-w64-mingw32                                              
GDAL: 2.2.1                                                                     
PROJ.4: 4.9.3                                                                   
GEOS: 3.5.0                                                                     
SQLite: 3.17.0                                                                  
Python: 2.7.5                                                                   
wxPython: 2.8.12.1                                                              
Platform: Windows-8-6.2.9200 (OSGeo4W) 

Change History (2)

comment:1 in reply to:  description Changed 2 years ago by hellik

Replying to hellik:

tested with

System Info                                                                     
GRASS version: 7.3.svn                                                          
GRASS SVN revision: r71600                                                      
Build date: 2017-10-27                                                          
Build platform: x86_64-w64-mingw32                                              
GDAL: 2.2.1                                                                     
PROJ.4: 4.9.3                                                                   
GEOS: 3.5.0                                                                     
SQLite: 3.17.0                                                                  
Python: 2.7.5                                                                   
wxPython: 2.8.12.1                                                              
Platform: Windows-8-6.2.9200 (OSGeo4W) 

the same issue in

System Info                                                                     
GRASS version: 7.2.2                                                            
GRASS SVN revision: r71496                                                      
Build date: 2017-09-20                                                          
Build platform: x86_64-w64-mingw32                                              
GDAL: 2.2.1                                                                     
PROJ.4: 4.9.3                                                                   
GEOS: 3.5.0                                                                     
SQLite: 3.17.0                                                                  
Python: 2.7.5                                                                   
wxPython: 2.8.12.1                                                              
Platform: Windows-8-6.2.9200 (OSGeo4W)

comment:2 Changed 2 years ago by hellik

Resolution: duplicate
Status: newclosed

closing ticket as duplicate of #2919

Note: See TracTickets for help on using tickets.