#3411 closed defect (duplicate)

testsuite: encoding error

Reported by: mlennert Owned by: grass-dev@…
Priority: normal Milestone: 7.2.2
Component: Tests Version: svn-releasebranch72
Keywords: testsuite encoding Cc:
CPU: Unspecified Platform: Unspecified

Description

Whenever a test fails in the testsuite, and the LANGUAGE is fr_BE, I get the following error message

Traceback (most recent call last):
  File "test_r_mapcalc.py", line 99, in test_seed_required
    self.assertModuleFail('r.mapcalc', expression='rand_x = rand(1, 200)')
  File "/data/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/etc/python/grass/gunittest/case.py", line 1180, in assertModuleFail
    module.run()
  File "/data/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/etc/python/grass/pygrass/modules/interface/module.py", line 769, in run
    self.wait()
  File "/data/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/etc/python/grass/pygrass/modules/interface/module.py", line 790, in wait
    module=self.name, errors=stderr)
  File "/data/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/etc/python/grass/exceptions/__init__.py", line 71, in __init__
    msg += _(". See the following errors:\n%s") % errors
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 37: ordinal not in range(128)

Change History (1)

comment:1 Changed 18 months ago by marisn

Resolution: duplicate
Status: newclosed

Duplicate of #2875

Note: See TracTickets for help on using tickets.