Opened 2 years ago

Closed 2 years ago

#3395 closed defect (duplicate)

t.rast.extract : encoding error

Reported by: mlennert Owned by: grass-dev@…
Priority: normal Milestone: 7.2.2
Component: Temporal Version: svn-trunk
Keywords: t.rast.extract encoding Cc:
CPU: Unspecified Platform: Unspecified

Description

And here's the next (after #3392, #3393, and #3394). I'll stop after this as this seems to be a fundamental issue in the whole temporal modules suite:

t.rast.extract input=pluies_nc output=tempmean_2010 where="start_time >= '2010-01-01' and start_time < '2011-01-01'"
Traceback (most recent call last):
  File "/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/scripts/t.rast.extract", line 106, in <module>
    main()
  File "/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/scripts/t.rast.extract", line 100, in main
    base, time_suffix, nprocs, register_null)
  File "/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/etc/python/grass/temporal/extract.py", line 189, in extract_dataset
    gscript.overwrite())
  File "/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/etc/python/grass/temporal/open_stds.py", line 174, in open_new_stds
    sp.insert(dbif)
  File "/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/etc/python/grass/temporal/abstract_space_time_dataset.py", line 378, in insert
    statement += AbstractDataset.insert(self, dbif=dbif, execute=False)
  File "/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/etc/python/grass/temporal/abstract_dataset.py", line 398, in insert
    statement += self.metadata.get_insert_statement_mogrified(dbif)
  File "/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/etc/python/grass/temporal/base.py", line 401, in get_insert_statement_mogrified
    mapset=self.mapset)
  File "/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/etc/python/grass/temporal/core.py", line 945, in mogrify_sql_statement
    return self.connections[mapset].mogrify_sql_statement(content)
  File "/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/etc/python/grass/temporal/core.py", line 1215, in mogrify_sql_statement
    str(args[count]),
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 2: ordinal not in range(128)

Change History (2)

comment:1 Changed 2 years ago by huhabla

This is horrible, who implemented this? It will need plenty of time to fix this. And i can not reproduce the translated error message UTF errors. Welcome to the UTF decode/encode error hell.

comment:2 Changed 2 years ago by mlennert

Resolution: duplicate
Status: newclosed

As this seems to be a general problem, all discussion should go on in #3392.

Note: See TracTickets for help on using tickets.