Opened 6 years ago

Closed 3 years ago

#3187 closed defect (worksforme)

Attribute table manager refreshing when connecting a distant sqlite database

Reported by: vincent Owned by: grass-dev@…
Priority: minor Milestone: 7.6.2
Component: wxGUI Version: svn-trunk
Keywords: database, layer Cc:
CPU: Unspecified Platform: Linux

Description

Given a vector map without layer, you may want to make a connection with an external database sqlite file. Doing this with the wxgui attribute table manager, when specifying the path for an existing sqlite file, 'Table' and 'Key column' dropdown lists are not immediately refreshed, so it is not possible to set properly the new layer. Update only happens if you select another entry in the 'Driver' dropdown list (e.g. 'pg'), then set it back to 'sqlite'.

Change History (2)

comment:1 by neteler, 4 years ago

Milestone: 7.0.67.0.7

comment:2 by martinl, 3 years ago

Milestone: 7.0.77.6.2
Resolution: worksforme
Status: newclosed

Unable to reproduce in GRASS 7.6.0.

Note: See TracTickets for help on using tickets.