Opened 11 years ago

Closed 11 years ago

#297 closed defect (fixed)

wxNVIZ: crash or failure

Reported by: msieczka Owned by: martinl
Priority: critical Milestone: 6.4.0
Component: wxGUI Version: svn-develbranch6
Keywords: nviz Cc: grass-dev@…
CPU: x86-64 Platform: Linux

Description

Starting w NVIZ I either get a complete wxGUI crash, with a following related entry in dmesg output:

python[982]: segfault at 68 ip 7f970909eb06 sp 7fff1f6dfb00 error 4 in libgrass_gis.6.4.svn.so[7f9709075000+64000]

or, a plain blank screen and an error on the terminal:

Gtk-CRITICAL **: gtk_range_set_range: assertion `min < max' failed

r33303

Change History (4)

comment:1 Changed 11 years ago by martinl

Cc: grass-dev@… added
Keywords: nviz added
Owner: changed from grass-dev@… to martinl
Status: newassigned

I cannot reproduce it. Can you send me sample location or exact commands which lead to this crash?

comment:2 Changed 11 years ago by msieczka

The crash takes place when the computational region is different than wxGUI display region.

E.g., in spearfish6:

  1. Set region away from data, g.region n=2 e=2 w=1 s=1 res=1 -a.
  1. Load 'elevation.dem' in wxGUI.
  1. "Zoom to selected map" on it.
  1. Start NVIZ - a complete wxGUI crash.

Apparently wxNVIZ depends on computational region. I think it should use the display region.

comment:3 Changed 11 years ago by martinl

Fixed in r33315.

comment:4 Changed 11 years ago by martinl

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.