Opened 3 years ago

Closed 3 years ago

#2934 closed defect (fixed)

Documentation error in i.vi WRT to MSAVI parameters

Reported by: pmav99 Owned by: grass-dev@…
Priority: normal Milestone: 7.0.5
Component: Imagery Version: 7.0.3
Keywords: i.vi Cc:
CPU: Unspecified Platform: Unspecified

Description

According to i.vi's documentation, the following input parameters are to be specified for MSAVI2 only:

soil_line_slope=float
    Value of the slope of the soil line (MSAVI2 only)
soil_line_intercept=float
    Value of the intercept of the soil line (MSAVI2 only)
soil_noise_reduction=float
    Value of the factor of reduction of soil noise (MSAVI2 only)

The formulas for MSAVI* are:

MSAVI = s(NIR-s*red-a) / (a*NIR+red-a*s+X*(1+s*s))	
MSAVI2 = (1/2)*(2(NIR+1)-sqrt((2*NIR+1)^2-8(NIR-red)))

AFAIK the formulas are correct, so I guess that the soil parameters should be required for MSAVI instead of MSAVI2. Is that accurate?

Change History (2)

comment:1 Changed 3 years ago by martinl

Milestone: 7.0.47.0.5

comment:2 Changed 3 years ago by neteler

Resolution: fixed
Status: newclosed

Yes. I had fixed that earlier this year (r69038 + backports).

Additionally added examples for each index in the manual in r69040 (msavi + wdvi yet unclear).

I close the ticket since I believe that the issue is addressed.

Note: See TracTickets for help on using tickets.