Opened 11 years ago

Closed 11 years ago

#293 closed defect (fixed)

wxGUI should provide a switch for region-constrained/free display mode

Reported by: msieczka Owned by: grass-dev@…
Priority: major Milestone: 6.4.0
Component: wxGUI Version: svn-develbranch6
Keywords: Cc:
CPU: All Platform: All

Description

wxGUI should provide an easily accessible switch for region-constrained/free display mode. Like gis.m does.

Change History (4)

comment:1 Changed 11 years ago by mlennert

On 06/09/08 19:51, Michael Barton wrote:

On Sep 6, 2008, at 4:03 AM, <grass-dev-request@…> wrote:

Message: 8 Date: Sat, 06 Sep 2008 10:53:32 -0000 From: "GRASS GIS" <trac@…> Subject: [GRASS-dev] [GRASS GIS] #293: wxGUI should provide a switch for region-constrained/free display mode To: undisclosed-recipients:; Message-ID: <042.c32e73800c23ec17093f4df5c04885a3@…> Content-Type: text/plain; charset="utf-8"

#293: wxGUI should provide a switch for region-constrained/free display mode


Reporter: msieczka | Owner: grass-dev@… Type: defect | Status: new Priority: major | Milestone: 6.4.0 Component: wxGUI | Version: svn-develbranch6 Keywords: | Platform: All Cpu: All |


wxGUI should provide an easily accessible switch for region- constrained/free display mode. Like gis.m does.

IIUC, this is linked to (a duplicate of ?) #106.

This is a feature request, not a defect. This kind of setting tries to have the image proportions inside the display window conform to the computational region proportions, rather than match the display window proportions.

[...]

Can you or others give some examples of actual display use that requires this kind of option (warranting the added complexity in display rendering that it involves) that cannot be achieved in another way?

In gis.m this mode does not necessarily conform to computational region proportions, but conforms to the proportions you indicate with your zoom. It can also be used to show the exact region proportions, something which I find extremely useful.

Now, maybe the fact that in the wx gui you can show the extent of the computational region solves this issue (although it doesn't solve the resolution issue raised in #106), I'll just have to work with it a bit more to really find out, but up to now I have found the absence of the constraint mode a nuisance...

Moritz

comment:2 in reply to:  1 Changed 11 years ago by martinl

Replying to mlennert:

Now, maybe the fact that in the wx gui you can show the extent of the computational region solves this issue (although it doesn't solve the resolution issue raised in #106), I'll just have to work with it a bit more to really find out, but up to now I have found the absence of the constraint mode a nuisance...

Helps?

Map display status bar ->

"Display mode"

Check "Constrain display resolution to computational settings"

Re-render

?

Untested, Martin

comment:3 Changed 11 years ago by mlennert

Works great for me for the resolution. Doesn't solve the original bug post concerning the region geometry. For me the display of the regional geometry as a red box solves this issue, though.

I would thus propose to close this bug, but will leave the decision to Maciej.

Moritz

comment:4 Changed 11 years ago by martinl

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.