Opened 4 years ago

Closed 20 months ago

#2880 closed defect (fixed)

Temporal GUI tools start with traceback from temporal/c_libraries_interface.py

Reported by: wenzeslaus Owned by: grass-dev@…
Priority: minor Milestone: 7.0.7
Component: Temporal Version: 7.0.2
Keywords: g.gui.timeline, g.gui.animation, RPC Cc:
CPU: Unspecified Platform: MSWindows 8

Description

Both g.gui.timeline and g.gui.animation start on MS Windows correctly but leave tracebacks related to subprocesses in C library remote procedure call interface.

g.gui.timeline:

Process Process-2:
Traceback (most recent call last):
  File "C:\Program Files (x86)\GRASS GIS
7.0.2\Python27\lib\multiprocessing\process.py", line 258, in
_bootstrap
    self.run()
  File "C:\Program Files (x86)\GRASS GIS
7.0.2\Python27\lib\multiprocessing\process.py", line 114, in
run
    self._target(*self._args, **self._kwargs)
  File "C:\Program Files (x86)\GRASS GIS
7.0.2\etc\python\grass\temporal\c_libraries_interface.py",
line 779, in c_library_server
    conn.poll(4)
IOError: [Errno 109] The pipe has been ended

g.gui.animation:

Process Process-4:
Traceback (most recent call last):
  File "C:\Program Files (x86)\GRASS GIS 7.0.2\Python27\lib\multiprocessing\proc
ess.py", line 258, in _bootstrap
    self.run()
  File "C:\Program Files (x86)\GRASS GIS 7.0.2\Python27\lib\multiprocessing\proc
ess.py", line 114, in run
    self._target(*self._args, **self._kwargs)
  File "C:\Program Files (x86)\GRASS GIS 7.0.2\etc\python\grass\temporal\c_libra
ries_interface.py", line 780, in c_library_server
    data = conn.recv()
EOFError

This happens both from command line and from GUI. Fortunately, the tools work as expected.

Change History (5)

comment:1 Changed 4 years ago by martinl

Milestone: 7.0.47.0.5

comment:2 Changed 3 years ago by neteler

Milestone: 7.0.57.0.6

comment:3 Changed 21 months ago by neteler

Milestone: 7.0.67.0.7

comment:4 Changed 20 months ago by veroandreo

is this still an issue?

comment:5 Changed 20 months ago by annakrat

Resolution: fixed
Status: newclosed

I can't reproduce it anymore.

Note: See TracTickets for help on using tickets.