Opened 4 years ago

Closed 14 months ago

#2863 closed defect (worksforme)

executing r.in.wms module causes pop up python gui error dialog (python.exe stopped working)

Reported by: tmsz Owned by: grass-dev@…
Priority: minor Milestone: 7.2.4
Component: Raster Version: 7.0.2
Keywords: r.in.wms Cc:
CPU: Unspecified Platform: MSWindows 7

Description

I just discovered that executing r.in.wms module (with default WMS_GRASS driver) causes pop up python gui error dialog (python.exe stopped working) (affected is a wxGUI Add web service layer dialog, too). However r.in.wms module finished correctly. This behaviour I discovered on Windows OS only.

r.in.wms url=http://watzmann-geog.urz.uni-heidelberg.de/cached/osm output=wms_eu_hillshade layers=europe_wms:hs_srtm_europa 

I debug r.in.wms module, and I find that behaviour cause src_band.ReadAsArray?() method call (ReadAsArray?() method from gdal python module), row 239 in the protected method _pct2rgb, class WMSDrv in the wms_drv.py module.

Attachments (1)

r_in_wms.jpg (140.3 KB) - added by tmsz 4 years ago.
python gui error dialog (python.exe stopped working)

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by tmsz

Attachment: r_in_wms.jpg added

python gui error dialog (python.exe stopped working)

comment:1 Changed 2 years ago by martinl

Milestone: 7.2.4

comment:2 Changed 14 months ago by martinl

Resolution: worksforme
Status: newclosed

No activity. Unable to reproduce in GRASS 7.6.1 (on Windows).

Note: See TracTickets for help on using tickets.