Opened 4 years ago

Closed 4 years ago

#2836 closed defect (fixed)

GUI modeller: errors when changing order of commands (indexation of items seems wrong)

Reported by: mlennert Owned by: martinl
Priority: normal Milestone: 7.0.4
Component: wxGUI Version: svn-releasebranch70
Keywords: modeller Cc: grass-dev@…
CPU: Unspecified Platform: Unspecified

Description

Using the GUI modeller in trunk and release70 I observe the following issues:

  1. first issue:
  • Add a command to the modeller
  • Add a second command to the modeller
  • Go to the items tab, select the first item and push on down (if you have more than two items this always works with the second to last item). Result:
Traceback (most recent call last):
  File
"/data/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64
-unknown-linux-gnu/gui/wxpython/gmodeler/frame.py", line
1662, in OnMoveItemsDown

self.list.MoveItems(items, up = False)
  File
"/data/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64
-unknown-linux-gnu/gui/wxpython/gmodeler/dialogs.py", line
972, in MoveItems

model.ReorderItems(idxList)
  File
"/data/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64
-unknown-linux-gnu/gui/wxpython/gmodeler/model.py", line
123, in ReorderItems

nextItem = self.items[newIdx+1]
IndexError
:
list index out of range
  1. Second (related) issue:
  • Add a loop
  • Add two commands and check the relevant boxes in 'List of items in loop'
  • Go to the Items tab
  • Select the second (lowest) item and push 'Up'

Result: both commands now have the label of the second command (the one that was moved up), even if the command behind that name is the command that was first before. When you move the top one 'Up' then it is the loop (item number 1, but hidden in the item list) that gets renamed.

Change History (6)

comment:1 Changed 4 years ago by neteler

Milestone: 7.0.3

Ticket retargeted after milestone closed

comment:2 Changed 4 years ago by neteler

Milestone: 7.0.4

Ticket retargeted after 7.0.3 milestone closed

comment:3 Changed 4 years ago by neteler

The modeller received some updates for 7.0.3, still an issue?

comment:4 in reply to:  3 Changed 4 years ago by mlennert

Replying to neteler:

The modeller received some updates for 7.0.3, still an issue?

Yes. Just tried with a fresh release70 and the issue is still there.

comment:5 Changed 4 years ago by martinl

Cc: grass-dev@… added
Owner: changed from grass-dev@… to martinl
Status: newassigned

Fixed in r68198 (trunk) and backported in r68199. Please close after testing.

comment:6 in reply to:  5 Changed 4 years ago by mlennert

Resolution: fixed
Status: assignedclosed

Replying to martinl:

Fixed in r68198 (trunk) and backported in r68199. Please close after testing.

I am still able to reproduce the second issue from time to time, but it seems to occur randomly. I haven't been able to create a systematically reproducible test case, yet.

So, I'm closing this for now and will open a new bug if the issue continues to appear.

Thanks !

Note: See TracTickets for help on using tickets.