Opened 5 years ago

Closed 5 years ago

#2747 closed defect (worksforme)

wxgui digitizer: display/update category values button does not work

Reported by: mlennert Owned by: grass-dev@…
Priority: major Milestone: 7.0.2
Component: wxGUI Version: svn-trunk
Keywords: vector digitizer categories Cc:
CPU: Unspecified Platform: Linux

Description

With a fresh trunk, in the wxgui, when I activate editing mode for a vector map, pushing on the button "Display/update categories" does nothing: I don't get the normal category editing window, I get no error message in the console or the terminal, just no reaction whatsoever.

As I can't even launch the gui in grass70_release at the moment, I don't know if this is specific to trunk, or not.

Change History (3)

comment:1 in reply to:  description Changed 5 years ago by mlennert

Replying to mlennert:

With a fresh trunk, in the wxgui, when I activate editing mode for a vector map, pushing on the button "Display/update categories" does nothing: I don't get the normal category editing window, I get no error message in the console or the terminal, just no reaction whatsoever.

As I can't even launch the gui in grass70_release at the moment, I don't know if this is specific to trunk, or not.

I have the same problem with a fresh grass70_release.

g.copy vect=census_wake2000,cw
g.gui.vdigit cw (or g.gui and activate editing)
try buttons 'Display/update categories' and 'Display/update attributes'

I get know reaction whatsoever. Not the usual popup, no error message, nothing.

Can anyone reproduce this ? This is a major usage issue for me at this stage.

comment:2 Changed 5 years ago by annakrat

I can't reproduce it, everything works normally. Tested also with wxpython 3, still no problem. Is your map 3D? That would explain it, but it's still a bug.

comment:3 in reply to:  2 Changed 5 years ago by mlennert

Resolution: worksforme
Status: newclosed

Replying to annakrat:

I can't reproduce it, everything works normally. Tested also with wxpython 3, still no problem. Is your map 3D? That would explain it, but it's still a bug.

I have no idea what happened. I tried several times yesterday, and couldn't get it to work. Now it works perfectly. At total loss here to explain...

For info: the map (census_wake2000) is not 3D.

Sorry for the noise. Closing the bug.

Note: See TracTickets for help on using tickets.