Opened 6 years ago

Closed 6 years ago

#2728 closed defect (fixed)

g.gui.animation (wx3): TypeError : in method 'new_SpinCtrl', expected argument 9 of type 'int'

Reported by: mlennert Owned by: grass-dev@…
Priority: normal Milestone: 7.0.2
Component: wxGUI Version: svn-trunk
Keywords: g.gui.animate Cc:
CPU: Unspecified Platform: Unspecified

Description

Using freshly checked out trunk, and trying to enter the settings dialog of g.gui.animation, I get:

Settings: unable to get value 'animation:nprocs:value'
Settings: unable to get value 'animation:nprocs:value'
Traceback (most recent call last):
  File
"/data/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64
-unknown-linux-gnu/gui/wxpython/animation/frame.py", line
297, in OnPreferences

dlg = PreferencesDialog(parent=self, giface=self._giface)
  File
"/data/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64
-unknown-linux-gnu/gui/wxpython/animation/dialogs.py", line
1479, in __init__

self._createGeneralPage(self.notebook)
  File
"/data/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64
-unknown-linux-gnu/gui/wxpython/animation/dialogs.py", line
1516, in _createGeneralPage

initial=UserSettings.Get(group='animation', key='nprocs',
subkey='value'))
  File "/usr/lib/python2.7/dist-
packages/wx-3.0-gtk2/wx/_controls.py", line 2344, in
__init__

_controls_.SpinCtrl_swiginit(self,_controls_.new_SpinCtrl(*a
rgs, **kwargs))
TypeError
:
in method 'new_SpinCtrl', expected argument 9 of type 'int'

Change History (3)

comment:1 Changed 6 years ago by annakrat

Not sure what's happening there, I can't reproduce... In the settings file (called wx) in your home folder, do you have a line starting with animation;nprocs;value? Most probably not, but that shouldn't be a problem. Could you run in any python console:

from multiprocessing import cpu_count
cpu_count()

that should give you an integer. Ideally, you could look what is actually passed to the SpinCtrl? constructor - should be integer, but apparently it's not.

comment:2 Changed 6 years ago by annakrat

My fault, try r66034.

comment:3 in reply to:  2 Changed 6 years ago by mlennert

Resolution: fixed
Status: newclosed

Replying to annakrat:

My fault, try r66034.

Fixed, thanks !

Closing.

Note: See TracTickets for help on using tickets.