Opened 5 years ago

Closed 3 years ago

#2677 closed defect (fixed)

mapswipe add raster map doesn't work with wxPython 3

Reported by: martinl Owned by: grass-dev@…
Priority: critical Milestone: 7.2.0
Component: wxGUI Version: unspecified
Keywords: mapswipe Cc:
CPU: Unspecified Platform: Unspecified

Description

Map Swipe doesn't allow to add raster map from toolbar, nothing happen, no error. Also statusbar is somehow broken, see attachment:mapswipe_statusbar_wx3.png

Attachments (1)

mapswipe_statusbar_wx3.png (2.3 KB) - added by martinl 5 years ago.
broken mapswipe statusbar (wxPython 3)

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by martinl

Attachment: mapswipe_statusbar_wx3.png added

broken mapswipe statusbar (wxPython 3)

comment:1 Changed 5 years ago by annakrat

Tested on Ubuntu with wxPython 3.0.1.1, I don't have any problems. Anyone else can test? Perhaps later wxPython version could be doing this?

comment:2 Changed 5 years ago by wenzeslaus

I can confirm the issues with status bar. My ends in half of the window. After resize, it spreads to the right positions but the select/choice box text is not fully visible. (We can't do much about this I think. Perhaps using our custom solution to get rich statusbars/bottom bars would be better (we are not using statusbar only for status)).

This might be also unrelated but when I run:

g.gui.mapswipe first=elevation second=aspect

I get Rendering failed: Expecting 809x515 image but got 951x640 image:

Traceback (most recent call last):
  File ".../gui/wxpython/core/gthread.py", line 116, in OnDone
    event.ondone(event)
  File ".../gui/wxpython/core/render.py", line 396, in OnRenderDone
    self.updateProgress.emit(layer=self.layer)
  File ".../etc/python/grass/pydispatch/signal.py", line 229, in emit
    dispatcher.send(signal=self, *args, **kwargs)
  File ".../etc/python/grass/pydispatch/dispatcher.py", line 349, in send
    **named
  File ".../etc/python/grass/pydispatch/robustapply.py", line 60, in robustApply
    return receiver(*arguments, **named)
  File ".../gui/wxpython/core/render.py", line 609, in ReportProgress
    self.renderDone.emit()
  File ".../etc/python/grass/pydispatch/signal.py", line 229, in emit
    dispatcher.send(signal=self, *args, **kwargs)
  File ".../etc/python/grass/pydispatch/dispatcher.py", line 349, in send
    **named
  File ".../etc/python/grass/pydispatch/robustapply.py", line 60, in robustApply
    return receiver(*arguments, **named)
  File ".../gui/wxpython/core/render.py", line 538, in OnRenderDone
    raise GException(_("Rendering failed: %s" % msg))
core.gcmd.GException: Rendering failed: Expecting 809x515 image but got 951x640 image.

This is my system (Lubuntu 14.10):

GRASS version: 7.1.svn                                                          
GRASS SVN revision: 65292                                                       
Build date: 2015-05-20                                                          
Build platform: x86_64-unknown-linux-gnu                                        
...
Python: 2.7.8                                                                   
wxPython: 3.0.0.0                                                               
Platform: Linux-3.16.0-38-generic-x86_64-with-Ubuntu-14.10-utopic 

comment:3 Changed 4 years ago by neteler

Milestone: 7.1.07.2.0

Milestone renamed

comment:4 Changed 4 years ago by martinl

The last comment is more than one year old, what is the status of this ticket? The related bug should be already fixed.

comment:5 Changed 3 years ago by neteler

Resolution: fixed
Status: newclosed

I checked on F24 (wxGTK3-3.0.2-19.fc24.x86_64), looks like fixed, all issues mentioned here are gone. Closing.

Note: See TracTickets for help on using tickets.