Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#2650 closed defect (fixed)

v.in.ascii - dropdown menu - gui components doesn't get update

Reported by: epifanio Owned by: grass-dev@…
Priority: critical Milestone: 7.2.0
Component: wxGUI Version: svn-trunk
Keywords: wxpython Cc:
CPU: OSX/Intel Platform: MacOSX

Description

'separator' and 'text' parameter are not updated in the command when an option is selected from the relative dropdown menu. To trig the update, an extra typing in the option textbox is required.

Change History (8)

comment:1 Changed 5 years ago by annakrat

I hoped I can reproduce it on my Ubuntu with wxPython3 but it works for me. What about the 'format' parameter, does it fail too?

comment:2 Changed 5 years ago by epifanio

On ubuntu it works fine. The problem is on OSX. I tried the format parameter and it works as expected. the issue are only on "separator" and "text" parameters. Thanks!

comment:3 in reply to:  2 Changed 5 years ago by annakrat

Replying to epifanio:

On ubuntu it works fine. The problem is on OSX. I tried the format parameter and it works as expected. the issue are only on "separator" and "text" parameters. Thanks!

that's really strange, these all should be the same widgets

comment:4 Changed 5 years ago by epifanio

I attached a short vide to show the behaviour. I agree it's strange and they are all the same type of widget.

http://144.76.93.231/shared/debugging/grassgui_v-in-ascii.mp4

comment:5 in reply to:  4 Changed 5 years ago by annakrat

Replying to epifanio:

I attached a short vide to show the behaviour. I agree it's strange and they are all the same type of widget.

http://144.76.93.231/shared/debugging/grassgui_v-in-ascii.mp4

Please try r65027 in trunk.

comment:6 Changed 5 years ago by epifanio

Resolution: fixed
Status: newclosed

It works grear, thank you!

comment:7 Changed 5 years ago by annakrat

Backported in r65028.

comment:8 Changed 4 years ago by neteler

Milestone: 7.1.07.2.0

Milestone renamed

Note: See TracTickets for help on using tickets.