Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#2646 closed defect (duplicate)

mac OSX - wxpython 3 (64 bit) create histogram of raster map fails to start

Reported by: epifanio Owned by: grass-dev@…
Priority: critical Milestone: 7.2.0
Component: wxGUI Version: svn-trunk
Keywords: Cc:
CPU: OSX/Intel Platform: MacOSX

Description

From the wxpytho gui -> Analyze map -> create histogram of raster map

the widget doesn't load, the following log is printed in the shell (full debug enabled) :

GRASS 7.1.svn (NAD83_UTM_18N):~ > GUI D3/5: BaseToolbar.OnTool(): id = 179
GUI D1/5: Map.__init__(): None
D1/5: grass.script.core.start_command(): g.tempfile -d pid=90304
D1/5: G_set_program_name(): g.tempfile
D2/5: G_file_name(): path = /Users/epi/grass7data/NAD83_UTM_18N/PERMANENT
D2/5: G_file_name(): path = /Users/epi/grass7data/NAD83_UTM_18N/PERMANENT/.tmp/epimac.local/90304.0
D1/5: grass.script.core.start_command(): g.gisenv -n
D1/5: G_set_program_name(): g.gisenv
D2/5: G_option_to_separator(): key = separator -> sep = '
'
GUI D1/5: gcmd.RunCommand(): g.proj -p
D1/5: grass.script.core.start_command(): g.proj -p
GUI D1/5: gcmd.RunCommand(): get return code 0 (0.043165 sec)
GUI D3/5: gcmd.RunCommand(): return stdout
'-PROJ_INFO-------------------------------------------------
name       : Universal Transverse Mercator
proj       : utm
datum      : nad83
ellps      : grs80
zone       : 18
no_defs    : defined
-PROJ_UNITS------------------------------------------------
unit       : meter
units      : meters
meters     : 1
'
Traceback (most recent call last):
  File "/usr/local/grass-7.1.svn/gui/wxpython/mapdisp/frame.py", line 1104, in OnHistogramPyPlot
    win = HistogramPlotFrame(parent = self, rasterList = raster)
  File "/usr/local/grass-7.1.svn/gui/wxpython/wxplot/histogram.py", line 39, in __init__
    BasePlotFrame.__init__(self, parent, size = size, **kwargs)
  File "/usr/local/grass-7.1.svn/gui/wxpython/wxplot/base.py", line 88, in __init__
    self.client = plot.PlotCanvas(self)
  File "/usr/local/Cellar/python/2.7.9/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/wx-3.0-osx_cocoa/wx/lib/plot.py", line 598, in __init__
    self.HandCursor = wx.Cursor(Hand.GetImage())
  File "/usr/local/Cellar/python/2.7.9/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/wx-3.0-osx_cocoa/wx/_gdi.py", line 1502, in __init__
    _gdi_.Cursor_swiginit(self,_gdi_.new_Cursor(*args, **kwargs))
TypeError: Required argument 'type' (pos 2) not found

Change History (2)

comment:1 Changed 5 years ago by annakrat

Resolution: duplicate
Status: newclosed

Duplicate of #2558.

comment:2 Changed 4 years ago by neteler

Milestone: 7.1.07.2.0

Milestone renamed

Note: See TracTickets for help on using tickets.