Opened 6 years ago

Closed 20 months ago

#2548 closed defect (fixed)

map display 3d view: error to display vector point

Reported by: hellik Owned by: grass-dev@…
Priority: major Milestone: 7.6.2
Component: wxGUI Version: svn-trunk
Keywords: Cc:
CPU: x86-64 Platform: MSWindows 7

Description

tested with

System Info                                                                     
GRASS Version: 7.1.svn                                                          
GRASS SVN Revision: 64069                                                       
Erstellungsdatum: 2015-01-12                                                    
Build Platform: i686-pc-mingw32                                                 
GDAL/OGR: 1.11.1                                                                
PROJ.4: 4.8.0                                                                   
GEOS: 3.4.2                                                                     
SQLite: 3.7.17                                                                  
Python: 2.7.4                                                                   
wxPython: 2.8.12.1                                                              
Platform: Windows-7-6.1.7601-SP1 (OSGeo4W)  

error message:

Traceback (most recent call last):
  File "C:\OSGeo4W\apps\grass\grass-7.1.svn\gui\wxpython\nvi
z\tools.py", line 2787, in OnSetRaster

self.UpdateSurfacePage(layer, data, updateName = False)
  File "C:\OSGeo4W\apps\grass\grass-7.1.svn\gui\wxpython\nvi
z\tools.py", line 4736, in UpdateSurfacePage

self.OnSurfaceAxis(None)
  File "C:\OSGeo4W\apps\grass\grass-7.1.svn\gui\wxpython\nvi
z\tools.py", line 3286, in OnSurfaceAxis

id = data['surface']['object']['id']
KeyError
:
'object'
Lade Rasterkarte <N47E012@myricaria>...
Lade Rasterkarte <N47E012@myricaria>...
Übersetze Farben der Rasterkarte <N47E012@myricaria>...
Vektorkarte <grosspoint2@myricaria> geladen (1 Punkte).

steps done:

  • load DEM to map display
  • load point vector (1 point) to map display
  • switch to 3d view

raster is displayed in 3d view, but not the vector

Change History (9)

comment:1 Changed 6 years ago by annakrat

I can't reproduce this on Ubuntu. Does this happen with fresh gui instance?

comment:2 in reply to:  1 Changed 6 years ago by hellik

Replying to annakrat:

I can't reproduce this on Ubuntu. Does this happen with fresh gui instance?

now tested with the nc sample data set

Starte 3D-Ansichtsmodus...                                                      
Lade Rasterkarte <elevation@PERMANENT>...
Lade Rasterkarte <elevation@PERMANENT>...
Übersetze Farben der Rasterkarte <elevation@PERMANENT>...
Vektorkarte <firestations@PERMANENT> geladen (15 Punkte).
Wechsle zu 2D-Ansicht zurück...                                                 
Rasterkarte <elevation@PERMANENT> erfolgreich entfernt                          
Vektorkarte <firestations@PERMANENT> (points) erfolgreich entfernt              
Starte 3D-Ansichtsmodus...                                                      
Traceback (most recent call last):
  File "C:\OSGeo4W\apps\grass\grass-7.1.svn\gui\wxpython\nvi
z\tools.py", line 2787, in OnSetRaster

self.UpdateSurfacePage(layer, data, updateName = False)
  File "C:\OSGeo4W\apps\grass\grass-7.1.svn\gui\wxpython\nvi
z\tools.py", line 4736, in UpdateSurfacePage

self.OnSurfaceAxis(None)
  File "C:\OSGeo4W\apps\grass\grass-7.1.svn\gui\wxpython\nvi
z\tools.py", line 3286, in OnSurfaceAxis

id = data['surface']['object']['id']
KeyError
:
'object'
Lade Rasterkarte <elevation@PERMANENT>...
Lade Rasterkarte <elevation@PERMANENT>...
Übersetze Farben der Rasterkarte <elevation@PERMANENT>...
Vektorkarte <overpasses@PERMANENT> geladen (117 Punkte).

to reproduce in nc sample data set:

- load elevation
- load firestation
- switch to 3d view
- switch back to 2d view
- remove firestation from map display
- add overpasses vector to map display
- switch to 3d view

comment:3 Changed 6 years ago by annakrat

So it seems Windows only problem.

comment:4 in reply to:  3 Changed 6 years ago by marisn

Replying to annakrat:

So it seems Windows only problem.

Observed the same problem on XP and Vista with 7.0.0

comment:5 Changed 5 years ago by martinl

Milestone: 7.0.07.0.5

comment:6 Changed 4 years ago by neteler

Milestone: 7.0.57.0.6

comment:7 in reply to:  3 Changed 4 years ago by hellik

Replying to annakrat:

So it seems Windows only problem.

tested by

System Info                                                                     
GRASS version: 7.2.svn                                                          
GRASS SVN revision: r69794                                                      
Build date: 2016-11-13                                                          
Build platform: x86_64-w64-mingw32                                              
GDAL: 2.1.2                                                                     
PROJ.4: 4.9.3                                                                   
GEOS: 3.5.0                                                                     
SQLite: 3.14.1                                                                  
Python: 2.7.5                                                                   
wxPython: 2.8.12.1                                                              
Platform: Windows-8-6.2.9200     

with the NC example mentioned above.

Starting 3D view mode...                                                        
Traceback (most recent call last):
  File "C:\Program Files\GRASS GIS
7.2.svn\gui\wxpython\nviz\tools.py", line 3247, in
OnSetRaster

self.UpdateSurfacePage(layer, data, updateName=False)
  File "C:\Program Files\GRASS GIS
7.2.svn\gui\wxpython\nviz\tools.py", line 5370, in
UpdateSurfacePage

self.OnSurfaceAxis(None)
  File "C:\Program Files\GRASS GIS
7.2.svn\gui\wxpython\nviz\tools.py", line 3784, in
OnSurfaceAxis

id = data['surface']['object']['id']
KeyError
:
'object'
Loading raster map <elevation@PERMANENT>...
Loading raster map <elevation@PERMANENT>...
Translating colors from raster map <elevation@PERMANENT>...
Vector map <overpasses@PERMANENT> loaded (117 points)

it's in the winGRASS7.0.x and winGRASS7.2.line.

comment:8 Changed 3 years ago by neteler

Milestone: 7.0.67.0.7

comment:9 Changed 20 months ago by martinl

Milestone: 7.0.77.6.2
Resolution: fixed
Status: newclosed

Tested with GRASS 7.6.1 on Windows 8, seems to work.

Note: See TracTickets for help on using tickets.