Opened 8 years ago

Last modified 3 years ago

#2534 reopened defect

i.segment.hierarchical install error

Reported by: dnewcomb Owned by: grass-dev@…
Priority: normal Milestone: 7.8.3
Component: Addons Version: svn-releasebranch70
Keywords: i.segment.hierarchical Cc:
CPU: x86-64 Platform: Linux

Description

When attempting to install the addon i.segment.hierarchical , I get the following error:

g.extension extension=i.segment.hierarchical svnurl=http://svn.osgeo.org/grass/grass-addons/grass7 Fetching <i.segment.hierarchical> from GRASS-Addons SVN repository (be patient)... Compiling... Makefile:17: warning: overriding commands for target `/tmp/t mpvNhswj/i.segment.hierarchical/etc/i.segment.hierarchical' /usr/local/grass-7.0.0svn/include/Make/ScriptRules.make:19: warning: ignoring old commands for target `/tmp/tmpvNhswj/i. segment.hierarchical/etc/i.segment.hierarchical' Traceback (most recent call last):

File "/tmp/tmpvNhswj/i.segment.hierarchical/scripts/i.segm

ent.hierarchical", line 158, in <module>

from isegpatch import rpatch_map

ImportError: No module named isegpatch make: * [i.segment.hierarchical.tmp.html] Error 1 ERROR: Compilation failed, sorry. Please check above error messages.

Change History (13)

comment:1 by martinl, 8 years ago

Component: DefaultAddons
Keywords: i.segment.hierarchical added

comment:2 by mlennert, 8 years ago

see also #2480, seems to be the same issue.

Moritz

in reply to:  2 ; comment:3 by dnewcomb, 8 years ago

Replying to mlennert:

see also #2480, seems to be the same issue.

Moritz

Interesting, i.segment.gsoc installed without a problem.

in reply to:  3 comment:4 by mlennert, 8 years ago

Replying to dnewcomb:

Replying to mlennert:

see also #2480, seems to be the same issue.

Moritz

Interesting, i.segment.gsoc installed without a problem.

That's a C-Module so different make logic. (And AFAIK it's actually superseded by i.segment in core).

Moritz

comment:5 by martinl, 7 years ago

Milestone: 7.0.07.0.5

comment:6 by martinl, 6 years ago

Resolution: worksforme
Status: newclosed

Tested with 7.0.5svn, i.segment.hierarchical installation works. I am taking liberty to close the ticket, feel free to reopen if needed.

in reply to:  6 comment:7 by mlennert, 6 years ago

Resolution: worksforme
Status: closedreopened

Replying to martinl:

Tested with 7.0.5svn, i.segment.hierarchical installation works. I am taking liberty to close the ticket, feel free to reopen if needed.

Reopening, since I can reproduce the error in trunk, but I think I found the reason:

g.extension i.segment.hierarchical
g.extension i.segment.hierarchical op=remove -f
g.extension i.segment.hierarchical

The first installation works, although I get the following warning:

Makefile:17: warning: overriding recipe for target '/tmp/grass7-mlennert-30404/tmpeM5UTQ/i.segment.hierarchical/etc/i.segment.hierarchical'
/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/include/Make/ScriptRules.make:19: warning: ignoring old recipe for target '/tmp/grass7-mlennert-30404/tmpeM5UTQ/i.segment.hierarchical/etc/i.segment.hierarchical'
Installing...
Makefile:17: warning: overriding recipe for target '/tmp/grass7-mlennert-30404/tmpeM5UTQ/i.segment.hierarchical/etc/i.segment.hierarchical'
/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/include/Make/ScriptRules.make:19: warning: ignoring old recipe for target '/tmp/grass7-mlennert-30404/tmpeM5UTQ/i.segment.hierarchical/etc/i.segment.hierarchical'
Updating addons metadata file...

However, the second installation attempt gives me the same error message as originally reported:

> g.extension i.segment.hierarchical
Fetching <i.segment.hierarchical> from GRASS GIS Addons repository (be
patient)...
Compiling...
Makefile:17: warning: overriding recipe for target '/tmp/grass7-mlennert-30404/tmpQxRkKD/i.segment.hierarchical/etc/i.segment.hierarchical'
/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/include/Make/ScriptRules.make:19: warning: ignoring old recipe for target '/tmp/grass7-mlennert-30404/tmpQxRkKD/i.segment.hierarchical/etc/i.segment.hierarchical'
Traceback (most recent call last):
  File "/tmp/grass7-mlennert-30404/tmpQxRkKD/i.segment.hierarchical/scripts/i.segment.hierarchical", line 154, in <module>
    from isegpatch import rpatch_map
ImportError: No module named isegpatch
make: *** [i.segment.hierarchical.tmp.html] Error 1
ERROR: Compilation failed, sorry. Please check above error messages.

The issue seems to be an emtpy ~/.grass7/addons/etc/i.segment.hierarchical directory. When I erase that directory, installation works again (with the above warnings).

comment:8 by mlennert, 6 years ago

When I install i.segment.hierarchical using the url parameter, I get the following warning:

> g.extension i.segment.hierarchical url=SRC/GRASS/grass-addons/grass7/imagery/i.segment.hierarchical/
Fetching <i.segment.hierarchical> from
</home/mlennert/SRC/GRASS/grass-addons/grass7/imagery/i.segment.hierarchical>
(be patient)...
Compiling...
Makefile:17: warning: overriding recipe for target '/tmp/grass7-mlennert-27332/tmpGjZYI8/i.segment.hierarchical/etc/i.segment.hierarchical'
/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/include/Make/ScriptRules.make:19: warning: ignoring old recipe for target '/tmp/grass7-mlennert-27332/tmpGjZYI8/i.segment.hierarchical/etc/i.segment.hierarchical'
Installing...
Makefile:17: warning: overriding recipe for target '/tmp/grass7-mlennert-27332/tmpGjZYI8/i.segment.hierarchical/etc/i.segment.hierarchical'
/home/mlennert/SRC/GRASS/grass_trunk/dist.x86_64-pc-linux-gnu/include/Make/ScriptRules.make:19: warning: ignoring old recipe for target '/tmp/grass7-mlennert-27332/tmpGjZYI8/i.segment.hierarchical/etc/i.segment.hierarchical'
Installation of <i.segment.hierarchical> successfully finished

It seems to me (but I'm no expert on Makefiles) that the Makefile is overly complicated. Could someone check on that ?

comment:9 by neteler, 6 years ago

Maybe follow the style of

grass-addons/grass7/imagery/i.fusion.hpf/Makefile

which also comes with extra .py files but a very simple Makefile

comment:10 by neteler, 6 years ago

Milestone: 7.0.57.0.6

comment:11 by neteler, 5 years ago

Milestone: 7.0.67.0.7

comment:12 by martinl, 4 years ago

Milestone: 7.0.7

Remove Milestone from Addons bugreports.

comment:13 by neteler, 3 years ago

Milestone: 7.8.3
Note: See TracTickets for help on using tickets.