Opened 5 years ago

Closed 5 years ago

#2527 closed defect (invalid)

r.relief not in menu

Reported by: cmbarton Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: wxGUI Version: svn-releasebranch70
Keywords: r.relief, r.shaded.relief Cc:
CPU: Unspecified Platform: Unspecified

Description

When r.shaded.relief was renamed to r.shade, it was not updated in the menu. So it is not accessible from the menu.

Attachments (1)

grass70svn_menu_rrelief_rshade.png (50.2 KB) - added by wenzeslaus 5 years ago.
GRASS GIS 7.0,0svn menu with r.relief and r.shade

Download all attachments as: .zip

Change History (11)

comment:1 in reply to:  description Changed 5 years ago by cmbarton

Keywords: r.relief added; r.shade removed

Replying to cmbarton:

When r.shaded.relief was renamed to r.shade, it was not updated in the menu. So it is not accessible from the menu.

It is r.relief that is not in the menu, not r.shade. Changing summary and other fields accordingly

comment:2 Changed 5 years ago by cmbarton

Summary: r.shade not in menur.relief not in menu

comment:3 Changed 5 years ago by annakrat

Resolution: invalid
Status: newclosed

It's already in Terrain analysis: http://trac.osgeo.org/grass/browser/grass/trunk/gui/wxpython/xml/toolboxes.xml#L786.

Make sure you do make distclean, or make clean in gui/wxpython.

comment:4 Changed 5 years ago by cmbarton

Sorry for the confusion if it is already there. I always do a make distclean before compiling. So why is that not working? Makes me wonder what else is missing.

comment:5 in reply to:  4 Changed 5 years ago by wenzeslaus

Replying to cmbarton:

Sorry for the confusion if it is already there. I always do a make distclean before compiling. So why is that not working? Makes me wonder what else is missing.

make distclean should be enough, I think, but make clean in gui/wxpython cannot harm. However, the compilation is somehow broken in two ways. The first is this one where changes are not properly recognized. I don't know how to improve the Makefile. The second issue (now unrelated) is the need to compile XMLs separately in GRASS session. It seems or seemed that MartinL fixed most of the problems with Ubuntu builds on Launchpad but it did not helped on Mac OS.

comment:6 Changed 5 years ago by cmbarton

Resolution: invalid
Status: closedreopened

This is missing on a fresh checkout of the beta 4 branch. I did not do an update. I am reopening.

Michael

Changed 5 years ago by wenzeslaus

GRASS GIS 7.0,0svn menu with r.relief and r.shade

comment:7 in reply to:  6 Changed 5 years ago by wenzeslaus

Replying to cmbarton:

This is missing on a fresh checkout of the beta 4 branch. I did not do an update. I am reopening.

I see both G7:r.relief and G7:r.shade in both latest 70 release branch and beta4 tag:

I can see them also in a freshly compiled and updated (after make distclean, svn up) GRASS in menu (attachment:grass70svn_menu_rrelief_rshade.png).

comment:8 Changed 5 years ago by cmbarton

The modules are there. The problem is that they are missing from the menu.

comment:9 in reply to:  8 Changed 5 years ago by wenzeslaus

Replying to cmbarton:

The modules are there. The problem is that they are missing from the menu.

Modules are in the toolbox (TerrainAnalysis which is in Raster), toolbox is in the menu. See:

which is in beta4 as explained by Markus in comment:4:ticket:2528.

Are you sure you are using the version complied from the fresh source code?

comment:10 Changed 5 years ago by wenzeslaus

Resolution: invalid
Status: reopenedclosed

This was a local problem. Please, open a new ticket if you have other issues.

Note: See TracTickets for help on using tickets.