Opened 5 years ago

Closed 3 years ago

Last modified 3 years ago

#2481 closed defect (worksforme)

g.gui.iclass: cannot display analysis results because of "No graphics device selected"

Reported by: mlennert Owned by: grass-dev@…
Priority: normal Milestone: 7.0.5
Component: wxGUI Version: svn-trunk
Keywords: g.gui.iclass d.mon Cc:
CPU: Unspecified Platform: Unspecified

Description

Using g.gui.iclass in both trunk and 70release, I do the following:

  • load group and subgroup
  • load vector training areas
  • "Run analysis"

I don't see any of the analysis maps (one per class) in the lower window, and I get the following error messages:

Data error preparing signatures: value (388) > num of cats
(256)
La commande 'd.rast map=eau_15961.0' a échoué
Détails :  No graphics device selected. Use d.mon to select
graphics device.
Data error preparing signatures: value (602) > num of cats
(256)
La commande 'd.rast map=veg_haute_15961.0' a échoué
Détails :  No graphics device selected. Use d.mon to select
graphics device.
Data error preparing signatures: value (394) > num of cats
(256)
La commande 'd.rast map=sol_nu_15961.0' a échoué
Détails :  No graphics device selected. Use d.mon to select
graphics device.
Data error preparing signatures: value (1173) > num of cats
(256)
La commande 'd.rast map=veg_basse_15961.1' a échoué
Détails :  No graphics device selected. Use d.mon to select
graphics device.
Data error preparing signatures: value (853) > num of cats
(256)
La commande 'd.rast map=bati_15961.1' a échoué
Détails :  No graphics device selected. Use d.mon to select
graphics device.
La commande 'd.rast map=pleiades_pan@PERMANENT' a échoué
Détails :  No graphics device selected. Use d.mon to select
graphics device.

What is really strange is that when I don't load the group and training areas, but only display an image in the upper or lower display window, I also get:

La commande 'd.rast map=pleiades_pan@PERMANENT' a échoué
Détails :  No graphics device selected. Use d.mon to select
graphics device.

but the image is displayed.

Using i.gensig and i.maxlik I can create valid signatures and a classification.

Change History (4)

comment:1 Changed 5 years ago by annakrat

I can't reproduce it. It seems that No graphics device selected and Data error preparing signatures are different problems. What kind of vector are you loading, the one you exported before from g.gui.iclass? What kind of data do you have in the group, I think, it can currently handle just 256 cats.

comment:2 Changed 3 years ago by martinl

Milestone: 7.0.07.0.5

comment:3 Changed 3 years ago by martinl

Resolution: worksforme
Status: newclosed

No activity last 22 months, closing, feel free to reopen if needed.

comment:4 Changed 3 years ago by mlennert

I'm currently getting a segfault trying to load vector training data, so I can't test. Need to rebuild to see if this is a local issue, but won't do that until after foss4g.

Note: See TracTickets for help on using tickets.