Opened 11 years ago

Closed 11 years ago

#244 closed defect (fixed)

v.in.ascii has no progress bar in any GUI (same as v.proj)

Reported by: msieczka Owned by: grass-dev@…
Priority: major Milestone: 6.4.0
Component: Vector Version: svn-develbranch6
Keywords: Cc:
CPU: All Platform: All

Description

v.in.asci has no progress bar in any GUI (same as v.proj)

Change History (5)

comment:1 Changed 11 years ago by glynn

Summary: v.in.asci has no progress bar in any GUI (same as v.proj)v.in.ascii has no progress bar in any GUI (same as v.proj)

comment:2 Changed 11 years ago by hamish

input can be piped from stdin, which is open-ended. So a progress bar isn't appropriate. r.in.xyz does some checks to see what kind of input is involved before checking filesize and rewinding, then using G_clicker() instead of G_percent(), but really for v.in.ascii IMO I don't think it's worth the trouble.

Hamish

comment:3 in reply to:  2 ; Changed 11 years ago by martinl

Replying to hamish:

input can be piped from stdin, which is open-ended. So a progress bar isn't appropriate. r.in.xyz does some checks to see what kind of input is involved before checking filesize and rewinding, then using G_clicker() instead of G_percent(), but really for v.in.ascii IMO I don't think it's worth the trouble.

It's seems to me that at least in points mode progress message info can be printed. The file is scanned before the points are imported, see r32398 (not backported to devbr6).

Martin

comment:4 in reply to:  3 Changed 11 years ago by hamish

Replying to martinl:

It's seems to me that at least in points mode progress message info can be printed. The file is scanned before the points are imported, see r32398 (not backported to devbr6).

i.e. in the first step of v.in.ascii the points are scanned for column type and sanitized then saved into a temporary file. then in a second step the temporary file is imported. G_percent() can work on the second stage as the number of points is known (r32398).

so shall we close this wish as "already done by martin"?

as it's not a bugfix I don't think backporting to 6.3/4 is appropriate.

regards, Hamish

comment:5 Changed 11 years ago by hamish

Resolution: fixed
Status: newclosed

sorry didn't check timestamps; change was done in response to this wish..

H

Note: See TracTickets for help on using tickets.