Opened 8 years ago

Closed 6 years ago

#2389 closed defect (worksforme)

Error in Grass-gis 7.1. svn

Reported by: Faraslis Owned by: grass-dev@…
Priority: normal Milestone: 7.0.5
Component: Startup Version: unspecified
Keywords: wingrass, grass.py Cc:
CPU: x86-32 Platform: MSWindows 7

Description

I install the grass-gis 7 beta 3. But when I try to launch i receive the message


nul=open <os.devnull, 'w'> IOerror: [Errno 2] No such file or directory : 'nul'


Also for the grass-gis 7 beta 2 and beta 1 I receive the same error message

My pc is win 7 32 bit

regards Giannis

Attachments (1)

grassmessage.jpg (42.1 KB ) - added by Faraslis 8 years ago.
Error message grass-gis 7

Download all attachments as: .zip

Change History (9)

by Faraslis, 8 years ago

Attachment: grassmessage.jpg added

Error message grass-gis 7

comment:1 by martinl, 8 years ago

Keywords: wingrass added
Milestone: 7.1.07.0.0

comment:2 by neteler, 8 years ago

Can you please try a fresh installer?

http://wingrass.fsv.cvut.cz/grass70/

in reply to:  description ; comment:3 by neteler, 8 years ago

Component: DefaultStartup
Keywords: grass.py added

Replying to Faraslis:


nul=open <os.devnull, 'w'>
IOerror: [Errno 2] No such file or directory : 'nul'


@devs, for the record:

grep -n 'nul = open' ./lib/init/grass.py 
409:            nul = open(os.devnull, 'w')
540:            nul = open(os.devnull, 'w')
1184:    nul = open(os.devnull, 'w')

in reply to:  3 comment:4 by glynn, 8 years ago

Replying to neteler:


nul=open <os.devnull, 'w'>
IOerror: [Errno 2] No such file or directory : 'nul'


Apparently, it's possible for the service implementing the null device ('nul' pseudo-file) to be stopped or to malfunction.

The status can be checked via the control panel. Start the Device Manager (Control Panel > Hardware and Sound > Device Manager), select View > Show hidden devices, then under Non-Plug and Play Drivers, there should be an entry for "Null".

The corresponding registry key is

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Null

The Start and Type values should both be 1.

comment:5 by neteler, 8 years ago

Does the problem persist with RC1?

in reply to:  5 comment:6 by messer, 7 years ago

Actually, I also experienced this bug on a win7 64bit notebook. I tried winGRASS beta3, RC1 earlier and today (23rd Feb) the stable 7.0.0 version. The 'Null' entry in Plug and Play Drivers and values in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Null were also checked and everything looked ok.

comment:7 by martinl, 6 years ago

Milestone: 7.0.07.0.5

comment:8 by martinl, 6 years ago

Resolution: worksforme
Status: newclosed

No activity last 18 months, closing, feel free to reopen if needed.

Note: See TracTickets for help on using tickets.