Opened 5 years ago

Closed 8 months ago

#2378 closed defect (worksforme)

t.list output lines mixed in wxGUI

Reported by: wenzeslaus Owned by: grass-dev@…
Priority: normal Milestone: 7.6.2
Component: wxGUI Version: svn-trunk
Keywords: temporal, t.list, stdout, stderr Cc:
CPU: Unspecified Platform: Linux

Description

When I use t.list in wxGUI Command console or from the generated dialog (form), I first get the section labels and then I get dataset names, so dataset are not printed in the right sections (i.e. mapsets).

It works OK in the standard command line. First I think that the problem is in GUI but it behaves nicely with g.mlist (can it be just a lucky coincidence that it works?). So, I don't know.

For example:

t.list columns=id,name

gives:

----------------------------------------------
Space time raster datasets with absolute time available in
mapset <climate_2000_2012>:
Space time raster datasets with relative time available in
mapset <NagsHead_series>:
precip_sum@climate_2000_2012|precip_sum
tempmean@climate_2000_2012|tempmean
tempmean_2010@climate_2000_2012|tempmean_2010
tempmean_F_summer@climate_2000_2012|tempmean_F_summer
tempmean_seasonal@climate_2000_2012|tempmean_seasonal
NagsHead_99_08@NagsHead_series|NagsHead_99_08

instead of (obtained in command line):

----------------------------------------------
Space time raster datasets with absolute time available in mapset <climate_2000_2012>:
precip_sum@climate_2000_2012
tempmean@climate_2000_2012
tempmean_2010@climate_2000_2012
tempmean_F_summer@climate_2000_2012
tempmean_seasonal@climate_2000_2012
Space time raster datasets with relative time available in mapset <NagsHead_series>:
NagsHead_99_08@NagsHead_series

While

g.mlist -p type=rast

works as expected:

----------------------------------------------
raster files available in mapset <NagsHead_series>:
NH_1999_1m          NH_2002_1m_interp   NH_2005_1m          NH_2008_1m
NH_2000_1m_interp   NH_2003_1m_interp   NH_2006_1m_interp   NH_2008_1m_0.05
NH_2001_1m          NH_2004_1m          NH_2007_1m
raster files available in mapset <PERMANENT>:
elev_state_500m

By the way, now I also see that t.list lists all mapsets while g.mlist just search path but this is for different ticket.

Change History (8)

comment:1 Changed 4 years ago by neteler

Milestone: 7.1.07.2.0

Milestone renamed

comment:2 Changed 3 years ago by neteler

Milestone: 7.2.07.2.1

Ticket retargeted after milestone closed

comment:3 Changed 3 years ago by martinl

Milestone: 7.2.17.2.2

comment:4 Changed 2 years ago by neteler

Milestone: 7.2.27.2.3

Ticket retargeted after milestone closed

comment:5 Changed 21 months ago by veroandreo

Is this still an issue?

comment:6 Changed 21 months ago by martinl

Milestone: 7.2.3

Ticket retargeted after milestone closed

comment:7 Changed 21 months ago by martinl

Milestone: 7.2.4

comment:8 Changed 8 months ago by martinl

Milestone: 7.2.47.6.2
Resolution: worksforme
Status: newclosed

Unable to reproduce with GRASS 7.6.0.

Note: See TracTickets for help on using tickets.