Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#2327 closed defect (fixed)

r.diversity = Illegal areas disposition

Reported by: sands Owned by: grass-dev@…
Priority: normal Milestone: 7.2.0
Component: Raster Version: svn-trunk
Keywords: r.li Cc:
CPU: x86-64 Platform: MSWindows 7

Description

When running r.diversity in GRASS GIS 7.1svn [60382] on Windows 7 64 (but with Python 2.7 win32) I get ERROR: Illegal areas disposition

With Helmut Kudrnovsky's help, I commented out lines 147-149 and 272-275 in r.diversity.py to keep the conf file and check it's contents, which appear fine:

conf_diversity_3.0: SAMPLINGFRAME 0|0|1|1

SAMPLEAREA -11|0.00631578947368|0.00569259962049

MOVINGWINDOW

I would appreciate any suggestions on what the error could be.

# CODE: Using nc_spm_08_grass7 g.gisenv set=DEBUG=1 g.region rast=lsat5_1987_10@landsat r.diversity --verbose input=lsat7_2002_10@PERMANENT prefix=t method=simpson,pielou """Results: D1/1: G_find_raster2(): name=lsat7_2002_10@PERMANENT mapset= D1/1: G_find_raster2(): name=lsat7_2002_10@PERMANENT mapset= D1/1: G_find_raster2(): name=lsat7_2002_10@PERMANENT mapset= D1/1: G_find_raster2(): name=lsat7_2002_10@PERMANENT mapset= D1/1: G_find_raster2(): name=lsat7_2002_10@PERMANENT mapset= D1/1: G_find_raster2(): name=lsat7_2002_10@PERMANENT mapset= D1/1: grass.script.core.start_command(): r.li.simpson input=lsat7_2002_10@PERMANENT conf=conf_diversity_3.0 output=t_simpson_size_3.0 D1/1: G_find_raster2(): name=lsat7_2002_10 mapset=PERMANENT D1/1: G_find_raster2(): name=lsat7_2002_10 mapset=PERMANENT D1/1: G_find_raster2(): name=lsat7_2002_10 mapset=PERMANENT D1/1: G_find_raster2(): name=lsat7_2002_10 mapset=PERMANENT D1/1: G_find_raster(): name=MASK mapset=landsat D1/1: G_find_raster2(): name=lsat7_2002_10@PERMANENT mapset= D1/1: r.li.daemon pathSetup: [C:\Users\Sands\AppData?\Roa ming\GRASS7\r.li\conf_diversity_3.0] ERROR: Illegal areas disposition D1/1: grass.script.core.start_command(): r.li.pielou input=lsat7_2002_10@PERMANENT conf=conf_diversity_3.0 output=t_pielou_size_3.0 D1/1: G_find_raster2(): name=lsat7_2002_10 mapset=PERMANENT D1/1: G_find_raster2(): name=lsat7_2002_10 mapset=PERMANENT D1/1: G_find_raster2(): name=lsat7_2002_10 mapset=PERMANENT D1/1: G_find_raster2(): name=lsat7_2002_10 mapset=PERMANENT D1/1: G_find_raster(): name=MASK mapset=landsat D1/1: G_find_raster2(): name=lsat7_2002_10@PERMANENT mapset= D1/1: r.li.daemon pathSetup: [C:\Users\Sands\AppData?\Roa ming\GRASS7\r.li\conf_diversity_3.0] ERROR: Illegal areas disposition (Fri Jun 06 07:24:02 2014) Command finished (0 sec)"""

Change History (4)

comment:1 in reply to:  description ; Changed 5 years ago by lucadelu

Keywords: r.li added; r.diversity removed

Replying to sands:

ERROR: Illegal areas disposition

The error in coming from r.li.daemon/daemon.c line 497. The problem is related to r.li suite not to r.diversity and only on Windows OS

comment:2 in reply to:  1 Changed 5 years ago by lucadelu

Replying to lucadelu:

Replying to sands:

ERROR: Illegal areas disposition

The error in coming from r.li.daemon/daemon.c line 497. The problem is related to r.li suite not to r.diversity and only on Windows OS

The problem should be fixed for r.diversity in r60779 and also for g.gui.rlisetup in r60780 and r60781.

I close the ticket, please reopen if needed

comment:3 Changed 5 years ago by lucadelu

Resolution: fixed
Status: newclosed

comment:4 Changed 4 years ago by neteler

Milestone: 7.1.07.2.0

Milestone renamed

Note: See TracTickets for help on using tickets.