Opened 6 years ago

Closed 5 years ago

#2220 closed defect (fixed)

d.vect fails to update layer list on map selection

Reported by: marisn Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: wxGUI Version: svn-trunk
Keywords: Cc:
CPU: Unspecified Platform: Unspecified

Description

#1605 has returned - with current trunk d.vect doesn't update vector layer list in its gui.

Steps to reproduce - run d.vect and choose a vector map with two layers.

I don't understand well the new GUI inner parts and thus only managed to figure out that forms.py line "p = self.task.get_param(self.eventId, element = 'wxId', raiseError = False)" results in None.

Could this be related to wxPython: 3.0.0.0 ?

Change History (2)

comment:1 in reply to:  description Changed 6 years ago by annakrat

Replying to marisn:

#1605 has returned - with current trunk d.vect doesn't update vector layer list in its gui.

This is a different issue but the same result.

Could this be related to wxPython: 3.0.0.0 ?

Yes, it is related. What puzzles me is that when you run d.vect from terminal, the layers are there correctly. The problem is that the layers are not updated but I have no clue what's going on so far.

comment:2 Changed 5 years ago by marisn

Resolution: fixed
Status: newclosed

Seems that this issue has been fixed at some point either by some GRASS changes or changes in wxPython. Closing for now. If someone still can reproduce with more recent version, just reopen it.

Tested with wxPython: 3.0.2.0 GRASS version: 7.1.svn 64677M on ~AMD64 GNU/Linux.

Note: See TracTickets for help on using tickets.