Opened 6 years ago

Closed 6 years ago

#2214 closed defect (fixed)

animator fails to render a second time

Reported by: bhlevca Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: wxGUI Version: unspecified
Keywords: Cc:
CPU: x86-64 Platform: Linux

Description

The animator works if it is used only once. It one tries to use it a second time the rendering will fail.

Change History (10)

comment:1 in reply to:  description ; Changed 6 years ago by bhlevca

Replying to bhlevca:

The animator works if it is used only once. It one tries to use it a second time the rendering will fail.

Forgot to mention that GRASS needs to be closed and restarted in order to make the animator work again.

comment:2 in reply to:  1 Changed 6 years ago by annakrat

Are you talking about Animation Tool (command g.gui.animation)? Please be more specific how to reproduce the error, what does it mean second time?

Replying to bhlevca:

Replying to bhlevca:

The animator works if it is used only once. It one tries to use it a second time the rendering will fail.

Forgot to mention that GRASS needs to be closed and restarted in order to make the animator work again.

I doubt that. Restarting Animation Tool should be sufficient for whatever error is there.

comment:3 Changed 6 years ago by bhlevca

I am using g.gui.animation from the File-> Animation tool.

Second time means that if I want to create another animation without closing the tool and the whole GRASS environment. It works if I modify the existing animation ( parameters, add delete maps), but if fails for example if I set a new region.

I tried to restart the animation tool but I get Fail rendering even if I start a new animation

comment:4 in reply to:  3 ; Changed 6 years ago by annakrat

Replying to bhlevca:

I am using g.gui.animation from the File-> Animation tool.

Second time means that if I want to create another animation without closing the tool and the whole GRASS environment. It works if I modify the existing animation ( parameters, add delete maps), but if fails for example if I set a new region.

when I set new region and press rerender in the animation tool, I see the animation in the part specified by the region. Probably you have to write down detailed steps of what leads to error so that I can reproduce it.

I tried to restart the animation tool but I get Fail rendering even if I start a new animation

comment:5 in reply to:  4 ; Changed 6 years ago by bhlevca

Replying to annakrat:

I tried to replicate and I could not crash it anymore. I guess we'll have to close this until I find what was I doing, because I was not dreaming when I reported this.

Meanwhile I found that I cannot render two animations. I am using multiple raster files and not space time raster I am unable to have two animation in the list and render both. When I am trying to render the second one I am getting :

"Inconsistent number of maps, please check input data."

looking in the code I see that only one animation is allowed in non-temporal mode. Any reason for that? Thanks

if temporalMode == TemporalMode.NONTEMPORAL:
            if len(mapCount) > 1:
                raise GException(_("Inconsistent number of maps, please check input data."))

comment:6 in reply to:  5 Changed 6 years ago by annakrat

Replying to bhlevca:

Replying to annakrat:

I tried to replicate and I could not crash it anymore. I guess we'll have to close this until I find what was I doing, because I was not dreaming when I reported this.

I believe you, however without being able to reproduce it I can't fix it.

Meanwhile I found that I cannot render two animations. I am using multiple raster files and not space time raster I am unable to have two animation in the list and render both. When I am trying to render the second one I am getting :

"Inconsistent number of maps, please check input data."

looking in the code I see that only one animation is allowed in non-temporal mode. Any reason for that? Thanks

if temporalMode == TemporalMode.NONTEMPORAL:
            if len(mapCount) > 1:
                raise GException(_("Inconsistent number of maps, please check input data."))

That's probably a bad name for this variable. But anyway, you have probably inconsistent number of maps in each animation. You have to have the same number of maps in each animation when using non temporal mode.

comment:7 Changed 6 years ago by bhlevca

I know now hot to reproduce it:

1) Add many layers 2) start rendering 3) press cancel before the process is ended 4) Rendering error appears

Any subsequent attempts to render will fail unless GRASS is completely shut off and started again

comment:8 Changed 6 years ago by annakrat

Thanks, I can see it now. Should be fixed in r59344. Please confirm.

comment:9 Changed 6 years ago by bhlevca

Yes, it is fixed now.

I have a question is there any way that I can add a text automatically to the slides, let's say from an attribute of a vector layer? I know how to add it manually when I export the slides.

comment:10 in reply to:  9 Changed 6 years ago by annakrat

Resolution: fixed
Status: newclosed

Replying to bhlevca:

Yes, it is fixed now.

I have a question is there any way that I can add a text automatically to the slides, let's say from an attribute of a vector layer? I know how to add it manually when I export the slides.

No. You can create a new ticket and describe what exactly you would like to have.

Note: See TracTickets for help on using tickets.