Opened 6 years ago

Closed 6 years ago

#2198 closed defect (fixed)

g.gui.iclass doesn't work

Reported by: matmar Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: wxGUI Version: unspecified
Keywords: wxpython, g.gui.iclass Cc:
CPU: x86-64 Platform: Linux

Description

Hi list,

I am able to open g.gui.iclass but when I open the Class Manager, I'm not able to close it.
Furthermore, I'm not able to exit from the module GUI, so it is unusable for me. This is the linked error that I get every time I try to close something:

File "/home/matteo/software/grass7_trunk/dist.x86_64-unknown-linux-gnu/etc/gui/wxpython/iclass/frame.py", line 210, in OnCloseWindow
    self.GetFirstWindow().GetDigit().CloseMap()
AttributeError: 'NoneType' object has no attribute 'CloseMap'
GRASS 7.0.svn (WGS84_32N):~ > g.version -gr
version=7.0.svn
date=2014
revision=59093M
build_date=2014-01-19
libgis_revision=58670 
libgis_date="2014-01-10 20:31:02 +0100 (Fri, 10 Jan 2014) "

Thanks,

Matteo

Change History (3)

comment:1 Changed 6 years ago by wenzeslaus

I can reproduce it even just when trying to close just opened g.gui.iclass.

Traceback (most recent call last):
  File "/.../dist.../etc/gui/wxpython/iclass/frame.py", line 210, in OnCloseWindow
    self.GetFirstWindow().GetDigit().CloseMap()
AttributeError: 'NoneType' object has no attribute 'CloseMap'

No Class manager involved. It is actually strange that this code is invoked also from Class manager.

comment:2 Changed 6 years ago by martinl

This bug seems to be related to the recent changes in digitizer, please try out r59096.

comment:3 in reply to:  2 Changed 6 years ago by wenzeslaus

Resolution: fixed
Status: newclosed

Replying to martinl:

This bug seems to be related to the recent changes in digitizer, please try out r59096.

Thanks, it works now. I must say that I really don't understand how r59096 fixes that or why it was possible to produce the error by pressing the close button of Class manager.

Note: See TracTickets for help on using tickets.