Opened 6 years ago

Closed 6 years ago

#2091 closed defect (fixed)

r.series error in GRASS7 wxGUI

Reported by: richardc Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: wxGUI Version: svn-trunk
Keywords: r.series, wxGui Cc:
CPU: x86-32 Platform: Linux

Description

Hi,

The following error occurs when attempting to sum 8 rasters in r.series from the wxGUI.

However, I'm able to run r.series from the GRASS terminal window.

Cheers, Richard GRASS v57721 (on Linux Mint 13/Ubuntu Precise)

Traceback (most recent call last):

File "/home/rcooper/grass7/grass7_trunk/dist.i686-pc-

linux-gnu/etc/gui/wxpython/gui_core/forms.py", line 698, in OnRun?

ret = self._gconsole.RunCmd?(cmd, onDone = self.OnDone?)

File "/home/rcooper/grass7/grass7_trunk/dist.i686-pc-

linux-gnu/etc/gui/wxpython/core/gconsole.py", line 497, in RunCmd?

task = GUI(show=None).ParseCommand?(command)

File "/home/rcooper/grass7/grass7_trunk/dist.i686-pc-

linux-gnu/etc/gui/wxpython/gui_core/forms.py", line 2307, in ParseCommand?

mapset = grass.find_file(value, element)mapset? KeyError? : 'mapset'

Change History (6)

comment:1 Changed 6 years ago by richardc

comment:2 Changed 6 years ago by richardc

Version: unspecifiedsvn-trunk

comment:3 Changed 6 years ago by annakrat

I am not able to reproduce the error (Ubuntu 12.04). Does this happen always? What about different number of maps?

comment:4 Changed 6 years ago by richardc

I discovered r.series in wxgui works if 7 maps are input, but not 8?

comment:5 Changed 6 years ago by annakrat

Should be fixed in r57950. It's connected to #1808 and #1814, so these should be fixed now. The problem is that the gui dialog attempts to add mapset to the map name if missing. But in case of multiple maps the mapset is considered to be everything after the first @ which can be too long and then g.findfile crashes. So now it doesn't try to add mapset in case of multiple maps. It could add mapset for each of the maps but in case of a lot of maps it could slow down everything and I don't really know if adding mapsets is needed at all.

comment:6 Changed 6 years ago by annakrat

Resolution: fixed
Status: newclosed

It's probably fixed and I am closing the related tickets too.

Note: See TracTickets for help on using tickets.