Opened 6 years ago

Closed 3 years ago

#2062 closed defect (worksforme)

r.fillnulls: Input map has no holes || No NULL cells found

Reported by: zarch Owned by: grass-dev@…
Priority: normal Milestone: 7.0.6
Component: Raster Version: svn-trunk
Keywords: Cc:
CPU: x86-64 Platform: Linux

Description

I'm trying to use r.fillnuls to fill a CELL map [0] with four categories.

G70> g.region rast=tree_rm_small -p  # set the region
projection: 99 (Transverse Mercator)
zone:       0
datum:      osgb36
ellipsoid:  airy
north:      673614.75
south:      672309.75
west:       324718.25
east:       326676
nsres:      0.25
ewres:      0.25
rows:       5220
cols:       7831
cells:      40877820

G70> r.stats -c -l input=tree_rm_small  # check that the map has NULLs
 100%
1  7612219
2  10576095
3  10678651
4  7654913
* no data 4355942

But I got:

G70> r.fillnulls input=tree_rm_small output=tree_rm_small__fill
 100%
 100%
ERROR: Input map has no holes. Check region settings.
G70> r.fillnulls input=tree_rm_small output=tree_rm_small__fill method=linear
 100%
 100%
ERROR: No NULL cells found in input raster.

How can I solve it? Any hints?

Attachments (1)

rfillnulls__0.png (4.6 KB) - added by zarch 6 years ago.
raster map to fill with r.fillnulls

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by zarch

Attachment: rfillnulls__0.png added

raster map to fill with r.fillnulls

comment:1 Changed 6 years ago by marisn

As fillnulls is using spline interpolator to fill NULL areas, it wouldn't make any sense for category data as You seem to have (i.e. what is category 3.67?). I would rather tend to fix r.fillnulls to not accept CELL map type to prevent users from filling holes in categorized data sets.

comment:2 Changed 4 years ago by martinl

Milestone: 7.0.07.0.5

comment:3 Changed 3 years ago by neteler

Milestone: 7.0.57.0.6

comment:4 Changed 3 years ago by marisn

Resolution: worksforme
Status: newclosed

I could not reproduce the issue with 7.3 on Linux with provided data or with my own data.* If the problem still persists, a location with sample data should be provided for testing.

.* Of course, output of r.fillnulls on CELL data is FCELL/DCELL

Note: See TracTickets for help on using tickets.