Opened 11 years ago

Closed 10 years ago

#205 closed defect (wontfix)

warnings and errors when trying to print the display

Reported by: msieczka Owned by: grass-dev@…
Priority: major Milestone: 6.4.0
Component: wxGUI Version: svn-develbranch6
Keywords: Cc:
CPU: x86-64 Platform: Linux

Description

  1. add a map
  1. display it
  1. "Print display" - as the window pops up, following debug info is printed to terminal:
(python:23706): GnomePrint-WARNING **: Could not create filter from description 'GnomePrintFilterSelect': filter 'GnomePrintFilterSelect' is unknown

(python:23706): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(python:23706): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(python:23706): GnomePrint-WARNING **: Could not create filter from description 'GnomePrintFilterClip [ GnomePrintFilterMultipage ]': filter 'GnomePrintFilterClip' is unknown

(python:23706): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(python:23706): libgnomeprintui-CRITICAL **: gnome_print_layout_selector_load_filter: assertion `GNOME_IS_PRINT_FILTER (f)' failed

(python:23706): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

(python:23706): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

(python:23706): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

(python:23706): libgnomeprintui-CRITICAL **: gnome_paper_selector_load_paper_size: assertion `GNOME_IS_PAPER_SELECTOR (ps)' failed

(python:23706): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

(python:23706): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

(python:23706): GnomePrint-CRITICAL **: gnome_print_filter_reset: assertion `GNOME_IS_PRINT_FILTER (f)' failed

(python:23706): GnomePrint-CRITICAL **: gnome_print_filter_flush: assertion `GNOME_IS_PRINT_FILTER (f)' failed

(python:23706): libgnomeprintui-CRITICAL **: gnome_paper_selector_load_paper_size: assertion `GNOME_IS_PAPER_SELECTOR (ps)' failed

** (python:23706): WARNING **: could not set the value of Settings.Document.Filter, node not found

Change History (6)

comment:1 Changed 11 years ago by martinl

Hm, I am not getting these warnings on my machine (using Debian GNU/Linux Sid, wxPython from apt.wxwidgets.org, 2.8.8.0). I will check later.

Martin

comment:2 in reply to:  1 Changed 11 years ago by msieczka

Replying to martinl:

Hm, I am not getting these warnings on my machine (using Debian GNU/Linux Sid, wxPython from apt.wxwidgets.org, 2.8.8.0). I will check later.

I'm on Debian testing, amd64, same version of wxPython from the same source.

Maciek

comment:3 Changed 11 years ago by cmbarton

Resolution: worksforme
Status: newclosed

No errors on Mac (devbr6), though preview doesn't work. Maybe fixed or a local Gnome problem?

comment:4 Changed 11 years ago by msieczka

Resolution: worksforme
Status: closedreopened

In opposite to Mac, print preview works on Debian testing. But WARNINGS still crop out when I press the "Print" button in the print-preview dialog:

(shoofi:8312): GnomePrint-WARNING **: Could not create filter from description 'GnomePrintFilterSelect': filter 'GnomePrintFilterSelect' is unknown

(shoofi:8312): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(shoofi:8312): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(shoofi:8312): GnomePrint-WARNING **: Could not create filter from description 'GnomePrintFilterClip [ GnomePrintFilterMultipage ]': filter 'GnomePrintFilterClip' is unknown

(shoofi:8312): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(shoofi:8312): libgnomeprintui-CRITICAL **: gnome_print_layout_selector_load_filter: assertion `GNOME_IS_PRINT_FILTER (f)' failed

(shoofi:8312): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

(shoofi:8312): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

(shoofi:8312): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

(shoofi:8312): libgnomeprintui-CRITICAL **: gnome_paper_selector_load_paper_size: assertion `GNOME_IS_PAPER_SELECTOR (ps)' failed

(shoofi:8312): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

(shoofi:8312): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

(shoofi:8312): GnomePrint-CRITICAL **: gnome_print_filter_reset: assertion `GNOME_IS_PRINT_FILTER (f)' failed

(shoofi:8312): GnomePrint-CRITICAL **: gnome_print_filter_flush: assertion `GNOME_IS_PRINT_FILTER (f)' failed

Then, switching between the PDF and PS output options yields another set of warnings:

(shoofi:8312): libgnomeprintui-CRITICAL **: gnome_paper_selector_load_paper_size: assertion `GNOME_IS_PAPER_SELECTOR (ps)' failed

(shoofi:8312): libgnomeprintui-CRITICAL **: gnome_paper_selector_load_paper_size: assertion `GNOME_IS_PAPER_SELECTOR (ps)' failed

** (shoofi:8312): WARNING **: could not set the value of Settings.Document.Filter, node not found

Finally, when printing to PS the following pops up:

(shoofi:8312): GnomePrint-WARNING **: Could not create filter from description 'frgba': filter 'frgba' is unknown

And the output PS takes forever to render in Evince (never completes). Interestingly, there are 2 pages instead of 1.

The PDF output renders fine. However, also 2 pages instead of 1 (both with the same content).

Also, scale&arrow overlay brings a solid black polygon covering all the map content below the scale&arrow, in the ouput PDF.

comment:5 Changed 10 years ago by cmbarton

The wxPython GUI is set to use the platform native printing system, whatever that is. If I remember the more extended discussions, one cause of this is installation of an additional printing system with the Gnome windowing package. There is some kind of conflict with the wxPython access/implementation of the local platform printing system.

If I recall, this is an issue with some Gnome print installations on some Linux platforms--not all. It does not seem to affect non-Gnome (at least at the time of discussions) windowing packages, nor does it seem to affect Mac or Windows.

Whatever the problem is, however, it seems to be something with wxWidgets or the wxPython implementation of it, not something that we can fix in the GUI. I suppose that the best thing would to report this to the wxPython or wxWidgets list.

Does anyone object to changing it to "won't fix" (can't fix actually)?

Michael

comment:6 Changed 10 years ago by cmbarton

Resolution: wontfix
Status: reopenedclosed

I've heard no objections to closing this with wontfix. So I'm closing. This is a duplicate of #187 AFAICT. I'm closing that one too with a reference to this ticket.

Michael

Note: See TracTickets for help on using tickets.