Opened 6 years ago

Last modified 4 years ago

#2000 new defect

wxGUI: Add command layer becomes unusable

Reported by: hamish Owned by: grass-dev@…
Priority: normal Milestone: 6.4.6
Component: wxGUI Version: svn-trunk
Keywords: command layer Cc:
CPU: x86-32 Platform: MSWindows XP

Description

Hi,

the "Add command layer" option is mostly unusable on Wingrass since you can't see what you're typing, and becomes oddly placed to the right of the other layer's preferences button on all platforms after you add a regular map layer.

see attached screenshots.

also I notice if I add a "--ui" or "--help" term to the command layer they silently get stripped off instead of acting as expected; and if I add a non-image creating module command is used there (like r.mapcalc) it seems to be ignored, limiting the kind of imaginative light scripting you can do with it.

finally, if you press the Del key while editing text in that line, it deletes they layer line and everything you just carefully typed in. :-(

thanks, Hamish

Attachments (3)

add_cmd_layer1_XP.png (14.2 KB) - added by hamish 6 years ago.
wxgui add command layer on Windows XP
add_cmd_layer2_XP.png (15.0 KB) - added by hamish 6 years ago.
wxgui add command layer on Windows XP
add_cmd_layer_Linux.png (25.8 KB) - added by hamish 6 years ago.
wxgui add command layer on Linux

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by hamish

Attachment: add_cmd_layer1_XP.png added

wxgui add command layer on Windows XP

Changed 6 years ago by hamish

Attachment: add_cmd_layer2_XP.png added

wxgui add command layer on Windows XP

Changed 6 years ago by hamish

Attachment: add_cmd_layer_Linux.png added

wxgui add command layer on Linux

comment:1 in reply to:  description Changed 6 years ago by annakrat

Milestone: 6.4.36.4.4
Priority: majornormal

Replying to hamish:

Hi,

the "Add command layer" option is mostly unusable on Wingrass since you can't see what you're typing, and becomes oddly placed to the right of the other layer's preferences button on all platforms after you add a regular map layer.

see #1239, I thought I had fixed the first point already, the second one cannot be fixed easily

see attached screenshots.

also I notice if I add a "--ui" or "--help" term to the command layer they silently get stripped off instead of acting as expected; and if I add a non-image creating module command is used there (like r.mapcalc) it seems to be ignored, limiting the kind of imaginative light scripting you can do with it.

what is 'acting as expected'?

finally, if you press the Del key while editing text in that line, it deletes they layer line and everything you just carefully typed in. :-(

I am not going to fix any of these issues now for 6.4.3.

comment:2 Changed 4 years ago by neteler

Milestone: 6.4.46.4.6
Note: See TracTickets for help on using tickets.