Opened 7 years ago

Closed 4 years ago

#1925 closed enhancement (fixed)

Inherited Verbosity level for grass array .write()

Reported by: jradinger Owned by: grass-dev@…
Priority: normal Milestone: 6.4.4
Component: Python Version: svn-releasebranch64
Keywords: Cc:
CPU: All Platform: All

Description

Hi,

as already discussed in the GRASS dev mailing list here I recommend respectively would like to see e.g. the python function write() which is located here which writes an numpy array back into GRASS to behave like other GRASS modules concerning the inheriting of the verbosity level.

At the moment the function sets verbose=TRUE and if the function is used in a script the verbosity level is not inherited. I suggest to remove that line (verbose=TRUE) which might be an relict since development times (see mailing list discussion) and allow the inheriting. This issue might also exist for r.in.bin (source: Hamish).

Change History (7)

comment:1 in reply to:  description ; Changed 7 years ago by glynn

Replying to jradinger:

Done in r55684.

comment:2 in reply to:  1 ; Changed 7 years ago by jradinger

Replying to glynn:

Replying to jradinger:

Done in r55684.

Thank you. But probably needs also to be back-ported to GRASS devel and releasebranch. And what about r.in.bin (don't know were it is located).

comment:3 in reply to:  2 Changed 7 years ago by glynn

Replying to jradinger:

And what about r.in.bin

What about it?

If you're referring to this message, you're misunderstanding his comment. The issue is with grass.script.array passing verbose=True to r.in.bin, not with r.in.bin itself.

(don't know were it is located).

The source is in raster/r.in.bin; the binary is in $GISBASE/bin.

comment:4 Changed 7 years ago by hamish

Component: DefaultPython
CPU: UnspecifiedAll
Platform: UnspecifiedAll

comment:5 in reply to:  1 ; Changed 6 years ago by neteler

Milestone: 6.4.36.4.4
Version: unspecifiedsvn-releasebranch64

Replying to glynn:

Replying to jradinger:

Done in r55684.

Should this change be backported to lib/python/array.py ?

comment:6 in reply to:  5 ; Changed 6 years ago by glynn

Replying to neteler:

Should this change be backported to lib/python/array.py ?

Do you mean backported to 6.x?

If so: probably.

comment:7 in reply to:  6 Changed 4 years ago by neteler

Resolution: fixed
Status: newclosed

Replying to glynn:

Replying to neteler:

Should this change be backported to lib/python/array.py ?

Do you mean backported to 6.x?

If so: probably.

I don't see any easy backport to G6, closing - please use GRASS GIS 7 for this where it is implemented in a better way.

Note: See TracTickets for help on using tickets.