Opened 7 years ago

Closed 7 years ago

#1905 closed defect (fixed)

Import modules allow to import into northern UTM location southern data

Reported by: marisn Owned by: grass-dev@…
Priority: blocker Milestone: 6.4.3
Component: Projections/Datums Version: svn-releasebranch64
Keywords: v.in.ogr, r.in.gdal Cc:
CPU: Unspecified Platform: Unspecified

Description

Steps to reproduce:

  • create a new location from EPSG code 32636
  • create a new shapefile in QGIS with EPSG code 32736
  • import shapefile with v.in.ogr

Import should fail as there's a "small" difference between UTM 36N and 36S but GRASS just announces "location appears to match" and imports file.

Blocking release as it might cause hard to catch nastiness later and might indicate more serious breakage in projection code matching. Sorry.

Tested on: 14th March WinGRASS 6.4.x 55376 (or whatever as it's not possible to copy revision number) Originally reported in ML. http://osgeo-org.1560.n6.nabble.com/bug-with-projection-systems-td5040244.html

Change History (3)

comment:1 in reply to:  description ; Changed 7 years ago by neteler

Replying to marisn: ...

Import should fail as there's a "small" difference between UTM 36N and 36S but GRASS just announces "location appears to match" and imports file.

The code in question is here: http://trac.osgeo.org/grass/browser/grass/branches/releasebranch_6_4/lib/gis/make_loc.c#L164 -> G_compare_projections()

There is no check for UTM in terms of "north" and "south". Since I always struggle with strings, no idea how to implement that. Might be easy, though.

comment:2 in reply to:  1 ; Changed 7 years ago by mmetz

Keywords: r.in.gdal added; r.in.ogr removed

Replying to neteler:

There is no check for UTM in terms of "north" and "south". Since I always struggle with strings, no idea how to implement that. Might be easy, though.

Fixed in trunk r55415.

Markus M

comment:3 in reply to:  2 Changed 7 years ago by neteler

Resolution: fixed
Status: newclosed

Replying to mmetz:

Fixed in trunk r55415.

Backported to 6.4.svn in r55427 and 6.5 in r55428.

Tested and closing.

Note: See TracTickets for help on using tickets.