Opened 7 years ago

Closed 6 years ago

#1893 closed defect (fixed)

d.vect on re-opening switches to default layer

Reported by: marisn Owned by: grass-dev@…
Priority: major Milestone: 6.4.3
Component: wxGUI Version: svn-releasebranch64
Keywords: Cc:
CPU: Unspecified Platform: Unspecified

Description

Steps to reproduce:

  • add vector layer
  • specify layer to draw (i.e. 2 or -1)
  • apply & close dialog
  • go to layer properties (opens d.vect)
  • check layer - it is correct but in second is changed to default one (1 in 6.4)

This is rather annoying as imagine following workflow: add vector map, select different layer (-1), change color and symbol. Close dialog. Decide to again change color/symbol. Open properties, change color, click Apply and KABOOM! Vectors are gone. Every time someone opens vector properties, he has to remember to set back layer option too.

Change History (8)

comment:1 Changed 7 years ago by annakrat

Please try r55181.

Anna

comment:2 in reply to:  1 ; Changed 7 years ago by mlennert

Replying to annakrat:

Please try r55181.

Works great for me.

Thanks !

Moritz

comment:3 in reply to:  2 ; Changed 7 years ago by mmetz

Replying to mlennert:

Replying to annakrat:

Please try r55181.

Works great for me.

Does not work for me in all branches with a network generated with v.net.

  1. Add a table to layer 2
  2. Display layer 2 with attributes (just cats for testing), click OK: ok
  3. Double-click on the layer in the lmgr, do nothing just click OK: KABOOM! Vectors are gone, error:
Details: attrcol not specified, cannot display attributes

It might be easier to just hide the dialog and show it again (like for decorations) on double-click or clock on Properties. The dialog then needs to be destroyed when the layer is removed. Makes sense?

Markus M

comment:4 in reply to:  3 ; Changed 7 years ago by mlennert

Replying to mmetz:

Replying to mlennert:

Replying to annakrat:

Please try r55181.

Works great for me.

Does not work for me in all branches with a network generated with v.net.

  1. Add a table to layer 2
  2. Display layer 2 with attributes (just cats for testing), click OK: ok
  3. Double-click on the layer in the lmgr, do nothing just click OK: KABOOM! Vectors are gone, error:
Details: attrcol not specified, cannot display attributes

It might be easier to just hide the dialog and show it again (like for decorations) on double-click or clock on Properties. The dialog then needs to be destroyed when the layer is removed. Makes sense?

I see the issue. IIUC, it's due to llayer. But wouldn't it be enough to apply a similar fix to llayer ?

Moritz

comment:5 in reply to:  4 ; Changed 7 years ago by mmetz

Replying to mlennert:

Replying to mmetz:

Replying to mlennert:

Replying to annakrat:

Please try r55181.

Works great for me.

Does not work for me in all branches with a network generated with v.net.

  1. Add a table to layer 2
  2. Display layer 2 with attributes (just cats for testing), click OK: ok
  3. Double-click on the layer in the lmgr, do nothing just click OK: KABOOM! Vectors are gone, error:
Details: attrcol not specified, cannot display attributes

It might be easier to just hide the dialog and show it again (like for decorations) on double-click or clock on Properties. The dialog then needs to be destroyed when the layer is removed. Makes sense?

I see the issue. IIUC, it's due to llayer. But wouldn't it be enough to apply a similar fix to llayer ?

No. You would need similar fixes for all column options as well. The dialog should IMHO not be updated when showing properties because the user did not update anything. IOW, the dialog and its options should only be updated when they are really updated (changed by the user). Thus my show/hide suggestion, which is already used for other dialogs.

Markus M

comment:6 in reply to:  5 Changed 7 years ago by annakrat

Replying to mmetz:

Replying to mlennert:

Replying to mmetz:

Replying to mlennert:

Replying to annakrat:

Please try r55181.

Works great for me.

Does not work for me in all branches with a network generated with v.net.

  1. Add a table to layer 2
  2. Display layer 2 with attributes (just cats for testing), click OK: ok
  3. Double-click on the layer in the lmgr, do nothing just click OK: KABOOM! Vectors are gone, error:
Details: attrcol not specified, cannot display attributes

It might be easier to just hide the dialog and show it again (like for decorations) on double-click or clock on Properties. The dialog then needs to be destroyed when the layer is removed. Makes sense?

I see the issue. IIUC, it's due to llayer. But wouldn't it be enough to apply a similar fix to llayer ?

No. You would need similar fixes for all column options as well. The dialog should IMHO not be updated when showing properties because the user did not update anything. IOW, the dialog and its options should only be updated when they are really updated (changed by the user). Thus my show/hide suggestion, which is already used for other dialogs.

Actually, the show/hide is already there. I just removed the line which updated the dialog. The llayer option seems to be a different problem which I don't fully understand. Only layer 1 is in the list.

Anna

comment:7 Changed 6 years ago by annakrat

This could be related also to #2012. The dialog now is not updated when shown. Can we close this ticket or is there something else?

comment:8 Changed 6 years ago by marisn

Resolution: fixed
Status: newclosed

Yes, this issue now is fixed.

Note: See TracTickets for help on using tickets.