Opened 7 years ago

Closed 7 years ago

#1890 closed defect (duplicate)

wingrass: launch grass terminal fails

Reported by: hamish Owned by: grass-dev@…
Priority: blocker Milestone: 6.4.3
Component: Startup Version: svn-releasebranch64
Keywords: wingrass Cc:
CPU: x86-64 Platform: MSWindows 7

Description

Hi,

when starting grass on a fairly fresh Windows7 install, if you try to launch the cmd.exe version of the grass terminal from the start menu ("GRASS $ver Command Line) you see a dos box flash up then disappear. If you try it from an already-running cmd.exe window you see the error at the DOS prompt:

The system cannot find the batch label specified -aftertextcheck

from then on the %PATH% is updated and many %GRASS_*% enviro variables exist, but grass hasn't really started up and grass modules will not run.

this is a regression from grass 6.4.2, I suppose some goto: related tragedy in the .bat file.

thanks, Hamish

Change History (2)

comment:1 Changed 7 years ago by hamish

Summary: wingrass: lauch grass terminal failswingrass: launch grass terminal fails

comment:2 Changed 7 years ago by msieczka

Resolution: duplicate
Status: newclosed

This is a duplicate of #1803, where I identified the root cause:

The problem is in the etc\Init.bat where the "aftertextcheck" label is used - looks like Windows expects "\r\n" at the end of the label name rather than "\n".

Closing this ticket and promoting #1803 to blocker.

Note: See TracTickets for help on using tickets.