Opened 7 years ago

Closed 7 years ago

#1880 closed defect (duplicate)

change color field to text for d.vect.chart

Reported by: cmbarton Owned by: grass-dev@…
Priority: major Milestone: 6.4.3
Component: Display Version: 6.4.2 RCs
Keywords: d.vect.chart, d.thematic.area, color arguments Cc:
CPU: All Platform: All

Description

The color argument for d.vect.chart is defined in such a way that the GUI converts it to a color chooser (interactive way to select colors) for the properties dialog in the layer manager.

The problem is that this field needs to accept MULTIPLE colors, not a single color. This is where the colors for different data fields are chosen so that they appear as different colors in the charts. A single color chooser makes this useless.

So unless there is a way for a color chooser to create a list of colors, this argument needs to be redefined as text that accepts a list of comma-separated colors.

Michael

Change History (2)

comment:1 Changed 7 years ago by hamish

Keywords: d.thematic.area added

The same is true for d.thematic.area, in devbr6 the gisprompt line has been commented out with a note about it:

grass/branches/develbranch_6/display/d.thematic.area/main.c#L118

Hamish

comment:2 Changed 7 years ago by annakrat

Resolution: duplicate
Status: newclosed

This is a duplicate of #1774 which has been fixed in 6.4 and 7 and now also in 6.5 (r55845).

Note: See TracTickets for help on using tickets.